2010 Throttle Lag on Cruise

Discussion in 'Touring Models' started by rebel1, Aug 9, 2009.

  1. rebel1

    rebel1 Member

    31
    16
    0
    Just got back from the first real ride on my 2010 Electra Glide Classic. I have a question about the "throttle by wire" system. When I have the cruise control set, and I want to increase my speed to pass, the throttle has to turn about 3/4 inch before it accelerates any! Is this NORMAL? Any info will be appreciated, before I call the dealer on tuesday.
    Thanks
    Bob
     
  2. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    i would say no i have almost no lag on my 08 with the tbw
     
  3. rebel1

    rebel1 Member

    31
    16
    0
    Is the 2008 a "throttle by wire" system or is it cable?
    Bob
     
  4. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    I did say i have TBW ... so yes its throttle by wire
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Ya sure there Bud? :lolrolling
     
  6. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    yeah im sure it does say TBW in my first post :p
     
  7. rebel1

    rebel1 Member

    31
    16
    0
    Sorry. I thought someone said that 08 was a combined system with TBW and a cable for the cruise????? I didn't see how that would work, so the question. Mine actually feels like I drop a slight amount of rpm before I get to where it starts accellerating. Do you know if they can reprogram or change anything to help?
    Bob
     
  8. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    nope there are no cables on the 08 .. they should be able to do something for ya.. maybe 1/8th at the most of a dead spot when on cruise and i roll on if even that .. yes it is different than when not using cruise
     
  9. glider

    glider Veteran Member

    25,464
    108
    44
    Trying to remember but someone posted about a download from the dealer for a problem , maybe this was it. I can't remember the issue or I would get it in a search for you.
     
  10. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    theres one for high idle on the tbw but havent heard of a dl for cruise problems