Rear Brake Light Switch

Discussion in 'Touring Models' started by bikernick, Dec 6, 2010.

  1. bikernick

    bikernick Member

    77
    16
    0
    I've got an 09 Road King with just under 20,000 miles on it. Went to start it up the other day and had a substantial amount of white smoke come up from the lower right hand side. I noticed it was near a switch and it had what appeared to be hydraulic fluid on the area. While I normally do my own maintenance, this was a new one for me so I had the bike towed into my Harley dealer.

    Turned out to be the rear brake light switch which had blown. My dealer replaced the switch and the brake fluid - no charge to me. Just wanted to post in case other riders have a similar problem and aren't aware of what it is.
     
  2. Cyclops

    Cyclops Active Member

    371
    28
    2
    Did the dealer/tech say why the switch failed prematurely? Just curious from a preventive perspective. Thanks! :57:
     
  3. bikernick

    bikernick Member

    77
    16
    0
    Cyclops - I didn't get an answer from the tech yet. He was busy working on another bike when I picked it up. I'm going back to talk to him though. That's one of the reasons I posted it.......I wanted to see if anyone else had experience with this problem.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    17,965
    153
    296
    Bad batch of switches maybe? would not surprise me today with quality control being a miss in foreign countries where a lot of vendors even Delphi get there goods, JMO I have had Calipers and wheel cylinders @ work made in Brazil with no threads in the casting for the brake lines Imagine that:p
     
  5. Btown Bagger

    Btown Bagger Member

    21
    11
    0
    Mine went bad on my 09 Street Glide at 14k
     
  6. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Mine went south on my 08 at around 36k.
     
  7. jimharvey1

    jimharvey1 Junior Member

    467
    28
    7
    Mine went out on my 07 UC. It didn't leak. Just the brake light stayed on constantly and, of course, the cruise didn't engage. The dealer changed out the tail light socket first as he thought he had a short there and then (after I got it back home and the brake light was back on constantly and I isolated the problem to the switch) he changed the switch for free. There was another bike in there for the same thing and on a ride a week later, one of the bike in the group suffered the same problem. If you look at where that switch is, it's pretty close to the y-pipe on the RH side and I think it's getting baked by the heat. I think a 90° elbow to angle the switch toward the center of the bike would solve all their problems. But why do that when you can sell $30 switches plus labor?
     
  8. Jack Klarich

    Jack Klarich Expert Member

    17,965
    153
    296
    I see a similar problem with the Dynas, The exhaust runs too close to the master cylinder IMO
     
  9. jaceddie

    jaceddie Junior Member

    928
    28
    1
    Mine went out around 35k miles on an 09 UC.
     
  10. wannaride

    wannaride Active Member

    259
    28
    2
    You were lucky, Ford has a "deactivation switch" for the cruise control that when it started to leak through the switch, it burned down the truck & everything around it. Brake fluid is flammable (DOT 3) not sure how flammable DOT 5 is. Glad you got it fixed.

    Toby