Idle and cruise control problems

Discussion in 'Touring Models' started by sccadrv, Jun 11, 2012.

  1. sccadrv

    sccadrv Member

    9
    0
    0
    I have a 08 Ultra Classic, with a problem that no one can seem to fix.
    To start with, the idol when hot (100 deg) outside will not hold at ~1 k unless I crank the throttle.
    Now this weekend, the cruise control dis-engages when rpms exceed 3100.
    Also showing codes, but no light for both frt/rear O2 high.

    Shop has replaced battery, re-pinned throttle, compensator, both O2 and a "Faulty brake switch".
     
  2. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    42
    What code(s) does it have?
     
  3. sccadrv

    sccadrv Member

    9
    0
    0
    P0132 and P0152.
    Both O2 have been replaced and this is the third time the codes have popped up in the last 3 weeks.
     
  4. ironmark

    ironmark Junior Member

    754
    28
    4
    The code shows that you are getting high voltage to the 02 sensors, it may be caused by a short in the wires or the 02 sensors. There can be a few things that can shut down the cruise, it could be either brake light switches or the clutch safety switch, since neither code is cruise control related the switches would be the first place to look. Is the bike going into limp home mode? Did the shop re-pin the throttle or the TCA (Throttle Control Actuator)? The Twist Grip Sensor (TGS) may be the problem too, the twist grip sensor is at the right hand side of your handlebars and it is your throttle control and it basically tells the bike how much fuel to give the engine the TGS will also shut down the cruise if the throttle is rolled forward, so if the potentiometer on the TGS is shorting out it will send false siginals to the ECM.
     
  5. the draggin

    the draggin Active Member

    151
    26
    0
    Man, this gets complicated..... What happened to the fun part?????:small3d031:
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Those DTC codes indicate your engine is running rich in both cylinders. That could be expected if you have done something to enrich the A/F ratio beyond the ECM's capacity to lean it back out.
    You did not say what your using for fuel enrichment. You told us nothing about the bike as far as mods that have been made etc.
     
  7. sccadrv

    sccadrv Member

    9
    0
    0
    No mods at all. Stock 2008 UC.
    Brake switches and clutch all disengage the cruise as advertised, as well as rolling the throttle forward.

    Step cruise for just under 3100, set the cruise..it holds, add throttle with cruise swith or throttle, and as it gets to 3100, cruise disengages.

    All work done by H-D Dealer Shops.
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    So you have a bone stock bike and your getting both a P0132 & P0152. You replaced both O2 sensors, cleared the codes and both codes re-appear in a short time.
    How many miles are on the bike. Is the air filter clean or new? Have you seen any other codes besides the 2 mentioned. At this time, the new O2 sensors are still installed in the bike. The new O2 sensors are Genuine HD.
     
  9. sccadrv

    sccadrv Member

    9
    0
    0
    32K.
    H-D replaced the O2 sensors, after 30 K service.
    If there were other codes, the shop cleared them, and did not tell me.
    The idle problem was the major problem, and it only shows up when it's hot outside. The problem is I live in Phoenix, AZ :)
    Cruise is the latest issue.
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    On a 2008, it's easy to pull and clear codes yourself. Are you doing it yourself, or is this 2nd hand information that the dealership is telling you. Do you have extended warranty on the bike or are you paying for repairs.