Can't Find Chirping Cricket -Like Noise 09 RKC

Discussion in 'Touring Models' started by danthern, Oct 27, 2013.

  1. danthern

    danthern Active Member

    298
    28
    2
    Hello to all...hope you can help me figure out this maddening noise on my 09 Road King Classic. Has the Screamin Eagle 103 Upgrade, about 47K. I've had it since 16K, ridden from Alabama to British Columbia, West Coast, etc. Been a great bike. Just recently she started with a sound that is most like a chirp from a cricket. It seems to be impossible to pinpoint where it's coming from. First I thought the primary, perhaps from the front end, no, maybe the right side....you get the picture. The dealer couldn't help. Their best recommendation was the Compensator but he admitted that he wasn't sure. It does it cold or hot and only when it's under a load. The noise stops when I release the throttle and is back with the slightest twist of the wrist. I installed the new SE Compensator kit, replaced the rubber bushings in the exhaust brackets, have checked every fastener that I can think of. The drive belt is within specs...I did check the forums here before this post. I know that noises can be unique but I hope that with these symptoms someone can point me in the way I need to go next. Thanks in advance!
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,510
    133
    212
    Have you checked the engine mounts? I have also heard the chirp noise from loose exhaust shields.
     
  3. blademan

    blademan Active Member

    179
    26
    0
    Lubricate your exhaust brackets at the rear of the muffler before you go to far. The rubber there was what caused mine.
     
  4. danthern

    danthern Active Member

    298
    28
    2
    Not the shields....they were rattling (I fixed them) but I haven't checked the engine mounts...I assume that would be near the base of the motor or are you talking about that crosspiece that runs across the top...?
     
  5. danthern

    danthern Active Member

    298
    28
    2
    I'll do that....the bushings are new but I'll slather it down anyway...certainly can't hurt. Thanks for the tips...keep em coming! I'll report back.
     
  6. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,510
    133
    212
    Check both the mounts and if you haven't checked in side the fairing you might want to look at the brackets that hold it to the bars.
     
  7. danthern

    danthern Active Member

    298
    28
    2
    Mounts are tight....It's a RK so no fairing but the hardware for the windshield is good and snug.
     
  8. 01 rk

    01 rk Active Member

    318
    28
    1
    My RK was doing the same thing I found it was the belt. Cleaning the front drive sprocket stopped it.
     
  9. Amish Hawg

    Amish Hawg Active Member Contributor

    251
    28
    5
    Mine's a tad older but that cricket a almost made me start drinking. The mounts for the pipes under the bags caused one of my squeaks. The cover for the fork lock was another. My biggest cricket........ the saddlebag brackets. At the bottom, closest to the fender, look at the bar coming down where it meets the bar going under the bag. Both sides of mine had hairline cracks. Only chirped when we rode 2 up.

    If possible, an car stethoscope for 5 bucks works wonders.

    Good luck..
     
  10. BUBBIE

    BUBBIE Well-Known Member

    4,974
    83
    124
    On my 09 FLHR, the windscreen (UK Talk):D was the noise... I removed the shield and lubed the rubber grommets with a little silicone spray... Holding on-to the shield while riding was the tell all....:s

    check it out.

    signed....BUBBIE