V&H straightshot & passenger footboard problems on a 2011 softail deluxe

Discussion in 'Softail Models' started by jeod, Mar 18, 2012.

  1. jeod

    jeod Member

    10
    0
    0
    Hi all

    I just installed vance & Hines straight shots on my HD softail deluxe 2011 and I have a problem with the passenger footboards that do not fit on the right side where the pipes are
    Can anyone help me or know a solution go this problem?

    Thanks in advance
     
  2. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Best to contact V&H at 1st chance, but need to check a few things while you're waiting:

    1. Make sure part# matches your bike (make/model/year).
    2. Re-check instructions for correct installation procedures.
    3. Check for any type of peg/board extension/adapter.

    I'm sure there's a easy fix - good luck & post some pics when you're done.
     
  3. jeod

    jeod Member

    10
    0
    0
    Thanks man,

    I've been looking for alternatives since Friday without any luck.

    I'll contact V&H on Monday, if they do not offer a solution I'll install the original pies back, since I have the footpeg look on my deluxe, even if I love the new sound of the bike now...

    I'll post some pics if somebody finds a solution(preferable V&H)

    Thanks!
     
  4. dbmg

    dbmg Experienced Member

    5,800
    153
    318
  5. jeod

    jeod Member

    10
    0
    0
    Thanks!

    The pipes are: STRAIGHTSHOTS: Performance Exhaust Systems

    and not only the slip-ons.

    The slip-ons will be an alternative if I cannot manage to get the footbard installed, but to install the slip-ons I need to re-install the stock pipes and them buy the straightshot slip-ons... and trash the straightshots

    I was assured that the pipes were compatible with the footbaords at my HD dealer, not truth after all.
     
  6. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Check this link out: STRAIGHTSHOTS: Vance Hines: Performance Exhaust Systems

    It looks likes the foot peg is on the bike. Again check part number...:s
    Check out fitment guide: SOFTAIL MODELS REQUIRE O2 SENSOR PLUGS 16925
    1986-2006
    I am thinking that the pipes are incorrect for your model...
     
  7. jeod

    jeod Member

    10
    0
    0
    yes,

    Not pb with the footpeg, the pb is with the footboard (I cannot yet post links), but you can search by HD part number: 50377-07A

    the footboard on the right side does not fett by half cm, if I force the footborad I'll smash the upper pipe.
     
  8. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    jeod; is there a way for you to get a pic uploaded...maybe to your garage...so we can get a visual.
     
  9. jeod

    jeod Member

    10
    0
    0
    attached some images

    thanks,
     

    Attached Files:

  10. jeod

    jeod Member

    10
    0
    0
    a few more and one on the left side, as you can see the footboards are made for this softail, the footpegs are ridiculous...

    Thanks for your help!
     

    Attached Files: