Turn Signal Problems

Discussion in 'Dyna Models' started by scooterb, Dec 24, 2008.

  1. scooterb

    scooterb New Member

    1
    11
    0
    I'm not getting any power to the right side turn signals, the green arrow on the dash don't light up on right, and turn signals are very dim and slow on left side. Wiring seems to check out, fuses ok. Could it be related to the silent alarm or a relay? Maybe a ground? Don't know what else to check. ?
     
  2. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Just a little more information, 1) what were the circumstances prior to the failure, was it after the bike and rider were washed or rained on? 2) Is the battery and bike on fairly regular maintenance schedule (on a battery tender when stored for over a week), garaged, and ran fine say the day before, etc. 3) Did you add modifications to the handlebar controls or service wiring or bar on either side' hand control groups? 4) Do you have meter, and fairly familiar with it' use and have documentation i.e. schematic/service manual to continue troubleshooting? Please advise...Thanks! :s
     
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    The obvious first. You have checked/replaced the turn signal bulbs/lights, right? Take them out, inspect them, clean the socket, clean the base of the lamp and replace, at least.

    TQ
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. mpgulyas

    mpgulyas Member

    27
    11
    0
    not sure, off the top of my head if the 2001 dyna had a tssm/tsm or a turn signal cancelation module .... either way not lighting upi the indicator arrows show a fault in the output from either module...fid out which you have and use a test light to check for signal from the switch , if that works check for signak out of the module.... if its the turn signal cancellation module, i've seen alot of those go bad ....i even have a good one ready for mine when it goes.:bigsmiley6:
     
  6. sasemmsun

    sasemmsun New Member

    1
    11
    0
    I had a simalar problem. my running lights worked fine, but when i hit my left turn signal, it dimmed to almost nothing. there are two filaments inside the bulb, one for running light and one for turn signal. when i turned the left turn signal on the running light filament was the one blinking, and the other filament never came on. anyway, i chased it down to a short in the wiring inside the frame under the gas tank. right where the two wire harnesses plug together. fixed the short and haven't had a problem since.
     
  7. whiterider

    whiterider Active Member

    105
    26
    0
    My '99 FXDX used to rub the wire under the rear guard to give the same symtoms.
    Every so often it would rub through the insulation. Usually after riding with a pillion and after a big bump in the road. Didn't matter how well it was clipped up and insulated (spiro-tie, heatshrink etc) after six months or so it would do it again. Might be worth a check.
     
  8. scottyboy134

    scottyboy134 New Member

    1
    0
    0
    does anyone know if my 1995 fxdwg has a cancellation module,because my right side lights light up but wont blink the green indercater light lights up and the left side works im lost thanks.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    [​IMG] Number 19 is your module Welcome to The Forum
     
  10. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    158
    If the light comes on but does not flash I would first suspect that the wrong bulbs are fitted as sufficient power needs to be drawn from the circuit to make the turn signal module flash
    If led or other low watt bulbs are fitted a load equaliser also needs to be incorporated to create the correct draw of power

    Brian