rough running engine

Discussion in 'Engine, Fuel and Exhaust' started by BobbyNova, Aug 8, 2010.

  1. BobbyNova

    BobbyNova Member

    12
    0
    0
    :newsmile04: Hi everyone, can switching the leads to my fuel injectors cause the bike to run rough? 2005 electraglide runs rough from idle to 2000 rpm! Been to two dealers who tell me its ok. Went to independent who says bike has balance issues.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Glider talked about the injector wires in an older thread, bet that is the problem, check the wire harness and see if the wires are pinched try to wiggle the wires with bike running does it make a change?
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    I think this should shed some light on this.

    Injector Wire Swapped - Harley Davidson Community
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  5. BobbyNova

    BobbyNova Member

    12
    0
    0
    Thanks Glider& Jack.
    This has been going on for 4 months and $500. Still under service contract and seems H-D stealers reluctant to get involved. Called customer service in Mil. and took bike to different dealer who had bike for three weeks and got it back the same and was told bike is fine and its my imagination. well two fairing mmounts and a primary leak later I think there is something wrong! By the way took bike to H-D sales in cleve,Oh and was charged $304 for them to check for loose compensator & flywheel runout, result was runout .003 and compensator ok. They replaced cam cover gasket. I thought you had to remove primary to get at compensator. Also dont you have to pull motor and put flywheel on stand?
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    The runout can be checked in the bike. There's videos in the self help area to show how.

    The compensator cannot be checked without pulling the primary cover and that should have a replacement gasket when reinstalled.
     
  7. BobbyNova

    BobbyNova Member

    12
    0
    0
    Just a cam cover gasket was on bill. Got very unfreindly answers from tech
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Log a complaint with manager and The MOCO, that is baloney, techs should be user friendly as most are riders, if one of my techs at work treated a customer badly I would write him up maybe even fire him depending on how the situation went down
     
  9. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    That is pretty sad when a tech chastises a customer, if he pulled the proper cover, it should have been on the bill...shame on him. Now the question is whether the work was done which should be brought up with the Service Manager or Owner. Good call Jack...bad customer service is just that simple.
     
  10. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    With the economy the way it is and more dealer closings, the owner needs to be made aware of this type of employee behavior. If you get the same type of response from the owner or worse yet no response the MOCO needs to be written to. I know a phone call is easier but a well written letter will have to be acknowledged. If you write the MOCO be sure to send a courtesy copy to the dealer.