No oil Pressure..Dummy light on..

Discussion in 'Oil' started by Teamsterrider, Oct 11, 2010.

  1. Teamsterrider

    Teamsterrider New Member

    3
    0
    0
    I ride a 05 Electraglide classic with 76,000 miles on. Last week morning cold start the dummy light came on and stayed on for a few miles butt the light always went off. I checked oil level and it was just between fill and full so I topped it off. It did the same thing a couple more times but always went off. I also wanted to say that during this time I was riding in very heavy rain. Yesterday I started up and the light was on and also noticed no oil pressure, 30 miles into the ride the pressure was slowly building were it eventually got to above 30 on the guage. I have changed and strained the oil to see if any metal or orange plastic pieces were there and it is very clean with just a tiny bit of shiny sludge on the plug magnet. I have just taken the oil sending unit off and cleaned it and checked it visually to see if there was any thing stuck to it and it looks good and clean. I am still under the extended warranty so I am not to worried about the worst case senario. Any ideas that might help?????
     
    Last edited by a moderator: Oct 14, 2010
  2. wb4eje

    wb4eje Member

    34
    18
    1
    A couple of years ago I had some flakey oil pressure readings on my '05 Classic. I removed the sensor and screwed a mechanical oil pressure gage into the port where the sensor was. The mechanical gage read good oil pressure. I replaced the oil pressure sensor and all was good. I highly suggest an independent measurement of the oil pressure with a different gage to make sure. Even with an extended warranty your bike will be down for a long time for a rebuild and there is no telling what else they will screw up rebuilding your engine.
     
  3. kemo

    kemo R.I.P

    1,690
    48
    5
    wb4ege is giving you good advice. Get a mechanical oil press gauge and remove the sender and install the mech gauge and see what you get for pressure.
    kemo
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Do exactly what wb4eje says to do with the mechanical test guage.
     
  5. Teamsterrider

    Teamsterrider New Member

    3
    0
    0
    Thank you for your help with my problem. Do you know where I can get a manual guage? is it something that I can get at my local Parts store? Thanks Jerry D
     
  6. kemo

    kemo R.I.P

    1,690
    48
    5
    You can just buy a dash mounted oil press guage and a hardware kit from Harbor Freight or any parts store, you don't need a professional model. Find the fittings that you need (1/8" pipe thread I think) and the nylon tube and make up your pressure guage. Shoud cost you less then $20.
    ken
     
  7. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    I notice you have Both installed already...

    I would believe that you DO have a problem with oil pressure !!!!!!

    No cleaning or anything will Improve the Lack of Oil Pressure..

    If you have run it @ No oil pressure, the damage is done...

    If your warranty will pay for a rebuild,,,, I doubt if Normal Wear-n-Tear is covered????

    Read your extended warranty carefully to see What is Covered and How it is covered.... BEFORE you go in to the shop.. Hind sight IS 20/20 so get a head start!

    signed....BUBBIE

    You saying that the oil light has always went off sounds like the problem has had a LONG time to work Badly!
     
  8. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    +1 ^^^^^ Maybe oil pump going bad?
     
  9. Moe55

    Moe55 New Member

    2
    0
    0
    If you rode for 30 miles and nothing blew up or started making noise best bet is that the sender is bad. Start with the guage to make sure like has been suggested.
     
  10. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    It would be good to check again but If you read carefully his post there is a gauge already plus the idiot light.. His saying that it built up to 30# in about 30 miles eventually on the gauge ....


    signed....BUBBIE
    added comment

    Don't know what type of gauge he has and It Might be the sending unit For The Gauge..