Jetting Problems???

Discussion in 'Sportster Models' started by SilverBullet, Oct 25, 2008.

  1. SilverBullet

    SilverBullet Member

    27
    11
    0
    I put a SE 1 air cleaner kit on my 04 1200 today. It already had SE II slip-ons and ran fine. I put a 185 main jet and 45 pilot jet in, and it runs fine except for when I'm rolling down the road, normal speed. When I crack the throttle to pass or accelerate, it stumbles, and kind of bogs, but once you start getting up in the higher rpms it runs fine. I have a 180 main jet, should I try it? I also haven't played with the mixture screw, will that help?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Try putting 2- #4 brass washers under the clip to raise it up on the needle in the diaphragm. It will bring in the fuel a bit sooner. Hope you didn't drill the slide.
     
  3. SilverBullet

    SilverBullet Member

    27
    11
    0
    I didn't...Will steel washers work?
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Good deal, it can cause stumbling at low RPM's in colder weather.
     
  5. SilverBullet

    SilverBullet Member

    27
    11
    0
    Do the washers have to be brass? Do you think I could get away with adjusting the mixture screw or going back to the 180 main jet? I really don't want to have to take the carb off. Also, with my main jet screwed into the emulsion tube, it doesn't screw all the way into the carb body. It only goes about half way. Is that normal?
     
    Last edited: Oct 25, 2008
  6. glider

    glider Veteran Member

    25,464
    108
    44
    SilverBullet
    Please post your questions on the forum, it makes twice as much work to reply to a PM when you copy and paste the same question in a PM as you posted on the forum.

    Thanks
     
  7. SilverBullet

    SilverBullet Member

    27
    11
    0
    Sorry bout that! I wasn't sure which would be quicker, and I was in a bit of a bind. It runs perfect now! No more stumbling and no more popping on decel! Thanks for all the help!
     
  8. Technologist

    Technologist Member

    86
    18
    1
    Did it fix itself, or did you follow some of the advice given?

    I am only asking so that others can benefit from what you did (or didn't do)...
     
  9. SilverBullet

    SilverBullet Member

    27
    11
    0
    Sorry, lol... I was pm'ing glider....I added some washers and played with the fuel mixture screw
     
  10. Technologist

    Technologist Member

    86
    18
    1
    Thanks for the reply. I am about to add a couple brass washers (easily found at ACE hardware). Been running a 45 and 195, no change to needle (washers), but air mixture turned out 3.5 turns.

    Going to go to 48 / 195, w/ 2 washers... hopefully will be at 1 turn out, maybe 2.

    Then gonna do a plug chop and hope all is well. The biggest problem I have right now is weather change.... too cold now, and if I get it right, then I will have to adjust a little more next spring!