2003 Ultra

Discussion in 'New Member Introduction' started by Phantom2003Ultra, Aug 29, 2014.

  1. Phantom2003Ultra

    Phantom2003Ultra New Member

    0
    0
    0
    Well I just bought a 2003 Ultra with 46,000 on it and 23,000 on the motor. The motor was upgraded to 95 cu in and gear to gear with screaming eagle heads. I have a dyno sheet that puts in at 104 hp.
    I found this site because I have a check engine light on. The other day when I rode it to work the check engine light came on after I started the bike and then went out. When I was leaving work it did the same and then came back on and stayed on most of the way home turning off once and then coming back on.
    Along with this the voltage gauge shows only 10 when started and then will jump to 14 going down the rode. It stayed at 10 after the check engine light came on so I'm thinking my problem is somewhere in the charging system. It is 27 miles one way to work all back roads no lights :D
     
  2. Phantom2003Ultra

    Phantom2003Ultra New Member

    0
    0
    0
    I forgot I'm in Umatilla Florida. 56 years old and also have a 1966 FLH that will be looking for a new home shortly. I have had the 66 since 1990. This is my 3rd Harley my first was a 1978 Low Rider that I bought in 1979 I loved that bike!
     
  3. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,597
    103
    296
    Did it throw any codes? if so what are they.
     
  4. Phantom2003Ultra

    Phantom2003Ultra New Member

    0
    0
    0
    I just found out how to get the codes so I'll be doing that tonight.
     
  5. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Welcome from So. Texas.
    tourbox
     
  6. tourbox

    tourbox Senior Member

    1,311
    68
    54
    Chances are the Stator and or the Regulator are going bad. If you have an Shop Manual it should tell you how to test them. The test are also in the Self Help section here on the forum.
    tourbox
     
  7. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,597
    103
    296
    BTW, Welcome to the forum. Also how old is the battery? Try a load test on the battery and clean the connections and retighten them on battery.
     
  8. Phantom2003Ultra

    Phantom2003Ultra New Member

    0
    0
    0
    Yes I got that information and printed so I can check this weekend. This seems like a great site so far. Hopefully in the future I will be able to contribute some information. Right now not so much on the 2003 but I do know alot about the 66 :D
     
  9. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,597
    103
    296
    Good deal, that should give you a good starting point. :s
     
  10. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,597
    103
    296
    More then likely tourbox is correct, best to check for codes first,:bigsmiley11: then go from there. Electrical issues are a process of elimination so start with the most obvious first. Good luck and keep us posted.