09 street bob pig tail

Discussion in 'TFI Questions Answered By Dobeck' started by choochooharley, Apr 19, 2011.

  1. choochooharley

    choochooharley Member

    30
    0
    0
    I was just wondering if it was normal to have to use electical tape to plug the ecm pigtail in to the dobeck. I could not get either pig tail to snap in. The tfi pigtail fit in to the injector but the ecm pigtail would not plug into the tfi. I even tried using pliers to squeeze it together and only in succeeded in taking a small chunk out of the bikes pigtail.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Not normal to use anything to connect them. They should snap tightly together.
     
  3. choochooharley

    choochooharley Member

    30
    0
    0
    Ok so now what do I need to do....
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Check to see if you have the proper model for your application and if it is inspect the plugs to see why they aren't snapping together.
     
  5. choochooharley

    choochooharley Member

    30
    0
    0
    I have already double checked and everything I see says this model is for the 09 dyna which is what i have. a 09 street bob...the reason as far as I can tell is the pig tail on the tfi is too tall and wont allow the stock pig tail to engage all the way...
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    When Dobeck replies here, there's always the remote possibility that the unit has the wrong plugs but I'm sure they will solve it for you.

    Maybe try calling them, they have excellent tech support.
     
  7. choochooharley

    choochooharley Member

    30
    0
    0
    Ok thanks for the help thats kinda what i figured just wanted to see if anyone else had the problem
     
  8. DobeckTechSupport

    DobeckTechSupport Active Member Product Contributor

    149
    28
    2
    choochooharley -

    For your 09 HD Dyna the injector connectors should look like the attached picture. The Male connectors are shaved down from the original mold to make a better fit. Would guess you just received a unit where the shaved down part was not in the correct tolerance. Would have to wonder how old the unit actually is?

    Suggest to take a file to remove a little more plastic off the ends.
     

    Attached Files:

  9. choochooharley

    choochooharley Member

    30
    0
    0
    Ok ill try that the part was shipped directly from your warehouse.
    [​IMG]
     
  10. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Did you just buy it new, or used?