XIED and High, Rough Idle

Discussion in 'Touring Models' started by mooremco, Jul 26, 2008.

  1. mooremco

    mooremco New Member

    2
    11
    0
    Hello,

    I just installed the XIED's on a 2008 Ultra with 300 miles on it - only thing not stock is 2.5" Rush slip-ons...Bike ran absolutely perfectly, but heat was a big issue.

    After installing the XIED's, my idle leaped to 1300-1400 RPM's and is quite rough. Due to weather, haven't actually ridden bike yet, just started it in garage.

    Any and all thoughts would be very welcome - Nightrider seems to be unavailable until sometime Monday.

    Thank you,
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Your problems may not be associated at all with the IED's you installed. It's an on going problem with the 08 bikes with the throttle by wire setup.

    Read this.

    08 High Idle Issue - Harley Davidson Community
     
  3. Lancer

    Lancer Junior Member

    495
    28
    2
    I put XIEDS on my 2008 Ultra Classic along with a pair of Kerker slipons. I am very happy with both. I did get a heat reduction and better throttle with the XIEDS. It seemed though that putting Mobile 1 V twin did the most for the heat. It also seems I got the high idle right after I put the xieds on, do the procedure. (kill switch on, cycle the ignition 5 times, 5 seconds between cycles) That should fix the high idle. I did not put the xieds and slipons on until after the 1000 mile service which I had done at the dealer. I have not had had it go into the single cylinder mode since I have done the above. It had done that to me twice before I did the mods.I do live in Florida and damn hot has been an understatement.
     
  4. rocknrod

    rocknrod Member

    35
    16
    0
    You need to reset your idle. The Xieds have nothing to do with it.
     
  5. glider

    glider Veteran Member

    25,464
    108
    43
    Idle can't be reset by the owner, dealer service only.