Two compensator changes

Discussion in 'Touring Models' started by donee2shu, Apr 11, 2012.

  1. donee2shu

    donee2shu Member

    29
    11
    0
    Today I found the grinding, slamming, sound upon starting is cased by the compensator .....this same thing happened Nineteen months ago...so from purchase to first compensator change was 18 months, now from then to now has been 19 months , and the dealer or HD customer service has NO idea what is causing the problem! I maintain there HAS to be a causeitive problem ...anyone had this before and if so what was it ??? By the way, up to now I have NO problem with the dealer !!!! Also, once in a blue moon, pushing the starter button has zero results...............

    Since buying bike in Feb. 2012 I am now on the second replacement of the compensator [2008 ultra]..Both have been badly worn and the engine , upon starting , hammered, banged , and knocked like heck!! Neither the dealer or H_D customer service offers any cause factors....just replace to the tune of hundreds of dollars!!!! First compensator lasted 18 months, the second one lasted 19 months and I don't think I should have to pay for new ones every 18-19 months....Has anyone had this problem and if so how was it resolved...Mine is a 2008 HD ultra classic with 52K miles on it.........Thanks!
     
    Last edited by a moderator: Apr 11, 2012
  2. Rubyred

    Rubyred Senior Member

    1,020
    0
    11
    I believe that if we all did our due diligence this compensator would be on a government recall. I am not a big government guy but if you pay good money and you get the habitual "bang" on startup and HD's fix is a heavy duty compensator that tell me something is wrong with design. No matter the issue we should take the time to report these issues to. Home | Safercar -- National Highway Traffic Safety Administration (NHTSA). This is my opinion and I will start doing this myself also.
    [​IMG]
     
  3. Jack Klarich

    Jack Klarich Expert Member

    17,965
    153
    296
    Is this the stock or SE comp?
     
  4. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    3
    Re: Two compensator changes in 3 years

    I take that both of your posts are related to same bike? If so , your dates dont add up If purchased in Feb. of 2012? Did you buy the scoot from a HD dealer or individual?
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,265
    83
    226
    Re: Two compensator changes in 3 years

    I agree, or maybe we're just confused! Guess I read it the same as you.:small3d012:
     
  6. donee2shu

    donee2shu Member

    29
    11
    0
    The bike was bought from an HD dealer in Feb '09 and the first comp was stock while the second one was SE......Now the third will be an SE....Thanks all...............
     
  7. btsom

    btsom Active Member

    341
    38
    6
    What lubes have you been using in the primary so far?
     
  8. ultra limited

    ultra limited Member

    10
    0
    0
    2010 Ultra Limited with 24,000 miles. Compensator shot and making all kinds of racket when starting. Guess what 2011 all 103 motors went to se compensators. If you have a 2010 103 to bad so sad. Paid the same price as a 2011. Harleys customer services is bad at there best.
     
  9. donee2shu

    donee2shu Member

    29
    11
    0
    I have used nothing but Amsoil 20w50 motorcycle oil since draining factory oil at 1k miles. If anyone wants an "ear-full" of comp troubles, just Google "Harley Davidson compensator" and you'll get about 3+ pages to read about this same thing. It apparently started primarily with the 96cu. engines......But they have a real problem and they know about it too.........which is why supposedly all 103cu. motors come from the factory with the latest heavy duty SE comp! I just hope this latest of mine lasts as long as I keep the bike !
     
  10. glenalt

    glenalt Junior Member

    405
    26
    0
    Took mine, 2010 Limited, to the dealer this week for a tire, brake switch recall and mentioned the bang on start up again. They are replacing with a SE at no charge for the upgrade. Nice!!