Turn Signal issues that won't quit

Discussion in 'General Harley Davidson Topic' started by scrinch, Jul 22, 2009.

  1. scrinch

    scrinch Active Member

    I have been dealing with a issue on my HD 2001 Road King and Liberty SC this summer that just seems to keep on.

    The hack has it's own right directional lights plus the rear brake light also acts as a directional. I also have a headlight modulator installed.

    Sometimes the directional signal on the left side would flash 4 times regular...then 4 times fast then cancel. The right would flash at the regular rate then cancel after 8 flashes. This did not happen all the time. If I put my directionals on late they would often respond correctly cancelling after the turn. If am stopped and then put them on they will also sometimes respond correctly but often the left signal will flash 4 slow 4 fast and then continue fast until I turn.

    I read that the Badlands load equalizer lll would take care of problems like this so I ordered one and installed it according to directions. It worked for one time and then went back to the previous cycle of 4 long 4 short and cancel...I called the Badlands Company tech support and was told to disable the right rear directional on the bike. I was good with that because I always felt it might be confusing to cars behind to have both a directional on the bike and hack. No help.... So I ground off the terminal on the bike's right front directional bulb so only the running light would work. Now the right light is going 4 long 4 short and canceling. Man this is getting irritating and I also think it is dangerous not to have the directionals go for more than 8 cycles before they cancel.

    I have also pulled the main fuses more times than I can count to reset the computer modules.

    Other than doing hand signals does anyone have any suggestions on where to go from here.
  2. DonT1985

    DonT1985 Member

    The first thing that I would do is to go back to the beginning. Disconnect the wiring to the Hack. Disconnect the load equalizer. Bring the bike back to the way it came. Do the turn signals work properly? If they do, the additions are at fault. If not, then the bike is at fault. Harley designed this bike with three separate circuts for lighting (running, turn signal and stop). Any change in these systems such as LED lighting, adding more lights, or crossing systems (such as using one bulb for both stop and turn) will cause some interesting problems). Also the Hack has to have a good ground circut to the bike. Many problems have been solved by repairing the grounds. Nobody thinks of the frame as being a ground wire, but it is. Without a proper ground, electricity will feed back interupting other lighting systems. Add your wiring one system at a time,then check the operation. Ground first, then turn signal then stop light. You mentioned that you have one light that acts as a stop light and turn signal, now that is a cross in systems. Take your time and keep the systems separate and pay attention to detail. Make your connections clean and tight and pay attention to wiring colors. Good Luck with your repair.

  3. Spade5

    Spade5 Active Member

    I know this won't help but I usually try the simple things. I read your post several times and was not clear if both sides did the same thing. I would be tempted to swap the bulbs from left to right cleaning the bulb and socket contacts at the same time. It sounds like the load changes possibly after the bulb heats up some.

    I would also be curious about what it would do sitting still, engine off also trying the four way flashers and even appling the brake. If it works fine with the engine off, it could have something to do with the sensor that cancells the turn signal. I thought this worked with a combination of lean and distance but I wouldn't think you would get much lean with your rig.

    Over the years dirty connections and/or bad grounds have bit me many times. I wish I really knew something that would help you but I don't.
  4. scrinch

    scrinch Active Member

    Thanks for the thoughtful replies...It gives me a direction to go in.
    It is tough to figure as I bought the bike used and do not know what was done to wire the hack , how it was wired and by whom.

    Both sides do not do the same thing all the time. There are tiimes when the signal function properly. Unplugging the right turn signals on the bike caused the problem to migrate from the left turn signal to the right. So I am gonna search for a poor ground first.
  5. chicago Bob

    chicago Bob New Member

    I have a turn signal issue that seems to be common with Dyna's I have a 1997 Dyna FXDS convertible. It's kicking my butt. Here's my problem. The left turn signal seems to work fine all the time, but the right signal just burns steady when the right switch is depressed. This steady burn is very bright and very hot, but the bulb will not flash, here is the weird part for me, if you put on the emergency flashers, both lights flash as advertised. Does anyone out there have a clue of what is wrong. I read some posts from a member named Glider who seemed to be very knowledgeable especially about electrical issues, if you're our there Glider.....HELP. Thanks for any help you anyone can provide, As B/4, Chicago Bob.
  6. Vilemind

    Vilemind Member

    i have had this problem before with my light getting bright and very hot ,,, turns out the bulb was installed wrong,,,, i turned the bulb and tried it worked perfect. ever tried taking it out and turning it to a different position ?
  7. Chopper

    Chopper Senior Member

    Welcome Bob, is there any history before this started happening? Have you taken the bulb out and checked it, is it double filament?