TFI install - '05 Deluxe Help

Discussion in 'Softail Models' started by twoup, Oct 11, 2008.

  1. twoup

    twoup Active Member

    205
    26
    0
    Morning all,

    I'm having a hard time finding where two of the connectors on the TFI/DFO
    connect. I see where the two larger FUEL INJECTOR CONNECTORS go but
    I do not see where the two smaller connectors go. I do not see any connector
    types where they will fit.

    Please help.

    thanx

    Vince
     
  2. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    sounds like you got the one for a bike that has oxygen sensors. the 95 doesn't use oxygen sensors......I would think it would work with out having to hook it up to the Oxygen sensors, but I don't know for sure.:dknow, glider might know, or you could probably call the custom service and ask the people that make it.
     
  3. twoup

    twoup Active Member

    205
    26
    0
    Thanx Wildspirit97, maybe that's what they are for. Ordered unit from chart with my bike mods. Stock 88ci t/c. SE Stage 1 (air, pipes, download). I called support at Techlusion and they're open 8-5 Monday - Friday. Punched in 100 for George
    voice mail, doesn't go anywhere. Just keeps playing info commercial then drops. Punched in 0 for operator. No operator.

    Waiting for Glider to come on. He'll know. Or even Hobbit. Actually, there are
    a lot of folks here that will know.

    Vince (in wait mode)
     
  4. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    I could be wrong I never used the tfi, but I used the cobra fr2000 and I think it hooks up the same way, can you post a picture of the hook up?

    does it look like this?
     

    Attached Files:

    Last edited: Oct 11, 2008
  5. twoup

    twoup Active Member

    205
    26
    0
    nope...(trying to attach pics)
     

    Attached Files:

    Last edited: Oct 11, 2008
  6. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Assuming you got the correct model TFI for your application, those two plugs could be for the 02 sensors but you don't have them. Check for the proper TFI for your bike.
     
  8. twoup

    twoup Active Member

    205
    26
    0
    Morn'n Glider,
     

    Attached Files:

  9. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    as I posted above.....it "piggy backs" the injector wire.
     
  10. twoup

    twoup Active Member

    205
    26
    0
    Been there Wildspirit97, and the same instructions came with the unit.

    Step 5 says Disconnect the factory injector connectors from the fuel injectors and replace with the TFI injector
    connectors from the TFI unit, it does not matter which order they are hooked up. (For Touring see figure #6,7,8, Softail 5,6,7, and Dyna 4,5,6).


    I don't see anywhere any instruction for the other two connectors or a 'note'
    which says anything about the two smaller connectors.