TFI and O2 sensors

Discussion in 'Touring Models' started by so cal hoss, Jun 7, 2010.

  1. so cal hoss

    so cal hoss Member

    83
    0
    1
    My TFI arrived late today and the installation instructions suggest that I disconnect the O2 sensors behind the side cover. Will this trip an engine code? My FLTRX is a 2010 California model.
     
  2. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    i think there is a plug for the O2 sensors so codes are not throne,,
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    There should be 2 resistors with the TFI that plug into the 02 sensor harness plugs so you don't set any codes.
     
  4. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    No, the TFI connects into the O2 sensor plugs & takes control. Also, if you get realenergetic, you can remove the O2 sensors & plug them...glider posted the NAPA O2 plug part# (search for it). I did mine when I removed the exhaust for ceramic coating.
     
  5. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    On what year my 08 didnt plug into the TFi they had resistors as glider said
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
  7. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Mine's a 09 FLHX & the TFI was a 1252ST. The O2 sensors were disconnected & replaced w/plugs fromt he TFI. From there you can tie-wrap the O2 wire/connector, or remove them.
     
  8. so cal hoss

    so cal hoss Member

    83
    0
    1
    Thanks for all your help. There were no resistors in the kit so plugging the TFI into the O2 sensor harness makes perfect sense. What a great forum!
     
  9. Thorns

    Thorns Active Member

    205
    26
    0
    The 2010 TFI doesn't need the bypass resistors. Disconnecting the sensors won't throw a hard code (the light won't come on). Just disconnect the sensors under the right side side panel. It's best to take some electrical tape and seal the connectors and where the connector plugs into so dirt doesn't mess up the terminals (if you ever want to use the ECM in closed loop again). The TFI doesn't use the O2 sensors as the ECM is stays in open loop (whatever adjustments made by the TFI). AND, how would you plug the TFI into the O2 sensors????

    Thorns
     
  10. so cal hoss

    so cal hoss Member

    83
    0
    1
    Good point Thorns! My kit is the (FL 1254ST)made for the 2010 Touring. The pictures on the instruction sheet along with the pictures of this unit on their website shows the resistors are included in this kit. Instruction number "6" says to disconnect the Factory O2 connections under the right side cover. Having never installed a TFI, I had to question the wisdom of leaving the sensors disconnected. Your advise clarifies the procedure. Maybe Dobeck could be a little more detailed in their instructions. I have removed O2 sensor wires on vehicles and each time they threw a code. Your help is much appreciated!