Street Glide won't start

Discussion in 'Touring Models' started by maxxis10, May 13, 2012.

  1. maxxis10

    maxxis10 New Member

    3
    0
    0
    Hey there, I recently put 12" Yaffe Monkey bars on my 2011 Street Glide. I had a local shop internally wire the bars for me to speed up the process. Installed everything, and now the bike won't start. It turns over, has spark, and the fuel pump cycles when I flip the switch to run. Any ideas? I'm going nuts here!
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Welcome to The Forum, Are you sure the kill switch is not the problem, If you have spark and the pump is running it should start
     
  3. maxxis10

    maxxis10 New Member

    3
    0
    0
    When I flip the kill switch from off to run, the fuel pump cycles like it should before start up.
     
  4. oldhippie

    oldhippie Senior Member

    1,072
    58
    19
    Is it possible to have reversed the wiring to the pump, reversing the polarity?
    The pump would do its run but be running backwards.

    Recheck your wiring.
     
  5. Fritz

    Fritz Member

    84
    16
    0
    Fly by wire throttle. Those little wires are fragile.Got check engine light? Sounds like you need to pull the wiring on throttle side and check for damage.
     
  6. maxxis10

    maxxis10 New Member

    3
    0
    0
    Yeah, I'm thinking it's the throttle by wire. So the shop I paid to do the wiring denies that anything could be wrong with the wiring. He says something must be wrong with the bike itself. (Bike ran great, he wired the bars- Bike won't start). Seems simple to me to figure out what went wrong. Think I'm gonna hafta (EDIT) it up and take it to my local dealer :(
     
    Last edited by a moderator: May 14, 2012
  7. scsharp2260

    scsharp2260 Member

    33
    0
    0
    Usually a tbw issue the bike will start but will idle only. Maybe it's the clutch safety switch?

    Sent from my SAMSUNG-SGH-I777 using Tapatalk 2