Sticky neutral

Discussion in 'Softail Models' started by ausibatla, Oct 10, 2013.

  1. ausibatla

    ausibatla Member

    54
    16
    5
    G'day fella's. Hope you can advise on my problem. I have just bought a customised 1988 Springer and am having a hard time finding neutral.
    I've read the post about rolling while selecting it but it doesn't work.
    It's either in first or second and the neutral light is on when it's in these gears while trying to get it. After messing around for the length of a change of traffic lights it'll give a little click and all of a sudden it's in. Once in neutral properly the light will become brighter than it was while it was jumping from first to second. Weird, I know.
    Once I'm ready to roll again and drop it into first, it goes in with a clunk and the neutral light goes out and stays out when shifted into second as well. It only lights up in first and second while searching for neutral.
    Open to any and all advice.
    Cheers.
    :bigsmiley23:
    :AUSTRALIA
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    My first thought would be to check your tension on the primary chain. If that is correct you should proceed to adjusting you clutch and clutch free play.
     
  3. ausibatla

    ausibatla Member

    54
    16
    5
    Thanks HDDon for the advice. Free play is fine as is adjustment. Never thought primary chain could affect selecting neutral. Will check it out.
    Cheers.
     
  4. droach3

    droach3 Member

    12
    0
    1
    ausibatla Any luck? The bike I am getting has the same problem that the previous owner has just "delt with" rather than fixing it. I plan to fix it.
     
  5. ausibatla

    ausibatla Member

    54
    16
    5
    droach3, thanks for the reply mate. But unfortunately no luck.
    If you get yours soted please let me know.
    Cheers.