squeak up front

Discussion in 'Other Service and Maintenance' started by lowrider13, Jun 5, 2016.

  1. lowrider13

    lowrider13 Active Member

    113
    28
    1
    I have a 04 RK classic, lately I am getting a noise when bike is warmed up that sounds like a chirping noise 0r rubber against rubber maybe. I went I hit a bump it seems to be heard. It doesn't seem to do it when first out , but later in the ride it appears. Any help would be appreciated.
     
  2. joel

    joel Junior Member

    523
    38
    48
    I had an 03 RKC and had a squeek / chirp sound.
    Ended up being the rubber insulators on the rear mount for the mufflers. When up to temp and the noise is happening put your boot on the end of the muffler to see it it changes.
     
    roadking96 likes this.
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    I think Joel has you covered. I had the same problem on my '03 UC. Kept trying to oil/lube it which would work for a few weeks and then the noise would return. I finally just bit the bullet and replaced them with new isolators. Problem solved. I guess the elastomer just gets hard after a while exposed to high temps.

    Cheers,

    TQ
     
  4. lowrider13

    lowrider13 Active Member

    113
    28
    1
    Went out and jiggled the left exhaust and it does squeak a bit. I will change them out and hopefully this will end the noise.
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,602
    103
    296
    If you end up changing the rubber mounts pay attention how they come out so they can be installed the same way. Mounts can be put in backwards if you're not paying attention.
     
  6. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I'll be nice and not ask you how you know.
     
    Jeff Klarich likes this.
  7. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,602
    103
    296
    Exactly.
     
    HDDon likes this.
  8. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    I think we have all done that!!

    But good point Jeff.

    Cheers,

    TQ
     
    HDDon and Jeff Klarich like this.
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    The rubber in the muffler mounts need a bit of lube once in a while, Silglide works good
     
    Bodeen likes this.
  10. joel

    joel Junior Member

    523
    38
    48
    On a trip once while the noise was chirping away, I stacked a couple pennies between the rubber and the plate. Tightend it up good and noise was gone.