Speedometer problem, can someone plesae help

Discussion in 'Sportster Models' started by jrenegade13, Oct 18, 2007.

  1. jrenegade13

    jrenegade13 New Member

    Can someone please help!!!! I recently purchased t a 2003 883 Sportster with the speedometer not working and the turn signals not cancelling. After reading some boards, I cleaned off the sensor and put it back. Nothing! I changed the sensor (dealer part #74402-95B) and still nothing. I went ahead and purchased a new speedo off of ebay that came with all the wiring up to the sensor. Hooked it all up and still nothing. Everything turns on, lights up and displays the milage, but arrow does not move. I got so frustrated, I took it to a reputable harley shop that only works on harleys. They checked all the wires and said that my old sensor is good and that all the wiring is good from the sensor all the way up to the speedo. They also said that all the wires had continuety and nothing is shorted. They left my old sensor and said the problem must be the speedometer again. I took it right to the dealer. They had a speedo on hand which they connected. Once again, nothing. WHAT THE HECK. They told me to leave it and that they would have to check everything. Does anyone have any ideas? This is really stressing me.:28:
    Last edited by a moderator: Oct 19, 2007
  2. glider

    glider Veteran Member

    Has anyone checked the voltage TO the speedo sensor? It's about the only think you didn't mention.

    I edited your post to remove language which is against HDT rules.