so frustrated

Discussion in 'Sportster Models' started by ashenfang, Sep 12, 2008.

  1. ashenfang

    ashenfang Member

    40
    16
    0
    Well..I installed the TFI last week and spent some time riding/tuning and thought I had it pretty good. The bike had good take off, and nice steady cruise. Then the tempurature dropped about 20 degrees, and the air became a bit dryer....guess what, bike runs like crap. Was out for a ride with some friends and the bike would bog something terrible under acceleration and in higher gears. I tried adjusting the pots a bit, but still couldn't get it dialed in.

    I messed with it a bit more the other day, and got the bike running good again, then of course, a temp. change, and the bike runs like garbage. I didn't know this was going to be such a headache. I know lots of people swear by these things, but, how are you guys dealing with temp/enviroment changes? With out the O2 sensors, it seems that the fuel mixture becomes to rich or to lean fairly easy when these changes happen. At this point, I am ready to return it and get a PCIII or SERT and have my local indy do a dyno tune for $150 :small3d008:
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    I have used many of the TFI units even on my own and haven't found a problem like you are having. Temp and humidity will normally effect a motors running regardless of the unit used (even stock) but you may have other problems like maybe an intake leak or something that is effecting the running.

    The sporties are a bit more difficult to tune.