rolling thunder did me in!

Discussion in 'Touring Models' started by broncobob, May 31, 2011.

  1. broncobob

    broncobob Member

    27
    0
    0
    how lucky can i be. i spent to whole day at the pentagon parking lot just to have to take my bike home before the pression into dc. i have a 2007 ultra classic with 32k and the only problems that ive had with it since new was the ever so often heating issues that everybody else puts up with. after riding from the dealer to the pentagon she got real hot, gauge read at about 300-310. after sitting at the pentagon for 5 hours kick stands went up and my baby would start but she wouldn't idle. i had to keep the throttle open just enough so she would,nt die. she died 5 times at the parking lot but would fire back up with no problem. home we went and she ran great on the open road but she still won,t hold an idle. anybody else with this problem?
     
  2. cromedome

    cromedome Active Member

    264
    0
    3
    What oil do you run? Stock exhaust? Tuner for more fuel?
    Had my 09 Road Glide there, no problems at all with temps...at least with the bike...
     
  3. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    Idle problems are not uncommon on the '07's. The IAC can get gummed up, and needs to be cleaned. Also there was a service bulletin for a download called "torque smoothing". Look at this link, and I believe there are others in the self help "diagnostics and fuel injection" section. http://www.hdtalking.com/archive/index.php/t-18936.html
     
  4. broncobob

    broncobob Member

    27
    0
    0
    my bike has a stage one kit along with true dual exhaust and i use all hd lubes. i will check out the bulletins and i do thank you. i will pull the iac and give it a good cleaning too
     
  5. Unbalanced

    Unbalanced Member

    11
    0
    0
    Would check for an intake leak on the throttlebody flanges. This would cause the bike to not idle and die.