Roadking issues

Discussion in 'Electrical' started by ffmedic32, May 5, 2009.

  1. ffmedic32

    ffmedic32 Member

    17
    11
    0
    I have got a 2003 Roadking. Yesterday the speedo went crazy bouncing around, odometer does not work now, turn signals dont cancel, check engine light is on, and it stalls at stop lights sometimes now. I did pull the codes and got a code 16 (batt voltage)

    Any suggestions where to look next.
     
  2. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
  3. gs34

    gs34 Junior Member

    639
    28
    5
    Time to get out the manual and turn to the electrical troubleshooting.
    Get the meter out and check your battery voltage before you check anything else. You should have at least 12.5-12.65 volts on a fully charged battery.
    If you have less than that, then you need to find why.
    Use your manual or do a search here in the electrical forum. Plenty of good information available on the subject.
     
  4. ffmedic32

    ffmedic32 Member

    17
    11
    0
    I have 12.65 volts at battery. Engine running I have 12.10 volts at idle, no change with rpm. Stator pass ground check and has 20 VAC output at idle.

    Would a bad voltage regulator cause the other symptoms?
     
  5. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    Check out the post above from Windspirit97. Bet that is it!!

    TQ
     
  6. ffmedic32

    ffmedic32 Member

    17
    11
    0
    Ok, pulled the VSS and it is spotless. So thats not the issue unless its bad all together.

    For whatever reason the thing is charging now.
     
  7. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
  8. glider

    glider Veteran Member

    25,464
    108
    44
    That doesn't mean it's good. That sensor is a hall effect magnetic sensor and as such is difficult to test properly. From your description of the problem, I would replace the VSS.
     
  9. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0

    If those numbers are correct It doesn't sound like it's charging to me. I'd put a battery tender on it till the light turns green just to see if a low battery is causing a problem. If the speedo problem goes away with a fully charged battery then you have your answer, but my guess is that you may have a couple problems.
     
  10. glider

    glider Veteran Member

    25,464
    108
    44