RECEPTION PROBLEM "on" vs. "acc"

Discussion in 'Communications And Radio' started by SGT ROCK, Jan 11, 2011.

  1. SGT ROCK

    SGT ROCK Member

    10
    11
    0
    I have a 1999 FLHTC. The radio worked fine until recently. When the ignition is in the "on" position, some FM stations I used to receive are just static. If I move the ignition to the accessory position, they come in loud and clear. I'll appreciate any suggestions.
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,837
    83
    179
    If it does this with the engine off, I have no idea. If it's running, did you change plug wires?
    What was the last thing you remember doing to the bike before the reception went static?
     
  3. SGT ROCK

    SGT ROCK Member

    10
    11
    0
    I don't know when exacrly this started because I seldom use the radio. I noticed it after I put my tour pac back on and connected the antenna to the tour pack mount. (Hmmmm...maybe a rounding problem? I think I'll take the tour pack off and put the antenna back on the mount behind the saddlebag.

    The problem exists when the engine is running and when it isn't.

    I tried to put my Ipod with FM transmitter near the antenna but the radio didn't pick up the signal.

    Thanks for the thought.

    I mean a "grounding problem". But where?
     
    Last edited by a moderator: Jan 12, 2011
  4. SGT ROCK

    SGT ROCK Member

    10
    11
    0
    I've pretty much determined that there is a problem in the actual ignition switch, since the reception is fine in the accessory position and for a split second as I turn the ignition switch from "on" to the "off" position. Anybody know the HD part number? (1999FLHTC) I'm sure its not cheap so I'll shop on line for one but I can't find the number on any of the dealer sites.
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,837
    83
    179
  6. SGT ROCK

    SGT ROCK Member

    10
    11
    0
    That's a good site. I guess they don't just sell the ignition switch assembly w/o all the hardware. I don't need the lock, just the electrical part.
     
  7. Jack Klarich

    Jack Klarich Guest

    Have you checked your bike for recalls? I remember a recall on the switch on my 97FLHT, you can check it at HD website with your VIN or check here Harley Recalls - Harley Davidson Community
     
  8. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,620
    133
    239
    Try this link to a uk hd dealer site it has most of the parts lists from 1999 onwards
    you just need to search for what you need and it is the hd part number that is given

    Harley-Davidson Parts

    Brian
     
  9. SGT ROCK

    SGT ROCK Member

    10
    11
    0
    A new wrinkle. I noticed that the reception improved when I applied the brakes when I pulled into my garage last night. Then I realized that the tail light is off when the ignition is in the accessory position....hmmm all electrical stuff right next to the antenna! I started wiggling the antenna wire and got an intermittant good signal. Maybe its something as simple as a bad antenna wire. Its a cheap gamble to replace the wire. Off to the dealership with $14.00 wedged between my crossed fingers!