radio works in headsets....

Discussion in 'Communications And Radio' started by jonathan.d.ward3, Apr 11, 2012.

  1. jonathan.d.ward3

    jonathan.d.ward3 New Member

    2
    0
    0
    Hi everyone, I have a 2008 Elctra Glide and for some reason the headsets will work with the radio but when I switch it to the speakers i get nothing. The radio is factory and I have checked all the wires for a short. I do not know what to do, and I have been searching the web for a week now looking for an answer. If anyone could help me solve this problem I would greatly appreciate it .
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    If its a Ultra check rear switch for passenger. It maybe in the wrong mode.
     
  3. Dandekar

    Dandekar Member

    19
    0
    0

    If the Icon on the faceplate is changing when you use the switch, the switch is working, but the radio is not switching internally.
    Iron Cross Audio is probably your best source for information on The HK units as far as what else to check.
     
  4. Lancer

    Lancer Junior Member

    495
    28
    2
    I had this issue on my 08 Ultra, ended up being a short in the wiring bundle.
     
  5. jonathan.d.ward3

    jonathan.d.ward3 New Member

    2
    0
    0
    I have checked all the switches and looked for all shorts without pulling the actual radio out and cant seem to find anything wrong. I have the fairing off and will keep looking but so far no luck.
     
  6. Lancer

    Lancer Junior Member

    495
    28
    2
    It has been a while and it was repaired by HD under warranty. "They" told me it was in a wiring bundle under the radio.