radio promblems

Discussion in 'Touring Models' started by HOTROD 94, Dec 14, 2009.

  1. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    94 Ultra Classic radio appears to work fine but I only get sound in head set nothing in speakers, speaker on\off only has 5 wires on it but has 6 connecters all the fuses are good feel like:wall
     
  2. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    yes the seems to be fine it has contituity
     
  3. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    4 ohms on speaker nothing from wires
     
  4. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Can you unplug the headset to see if they work then.:57:
     
  5. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    yes still nothing
     
  6. Lancer

    Lancer Junior Member

    495
    28
    2
    I had this issue on an 08 Ultra, ended up the wires in the wiring harness had chaffed. The harness was routed under the radio and apparently rubbed on it. I had sound the the headset but none from the speakers.
     
  7. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    I just relized if both headsets are plugged in you don't have to push the PTT button (thanks to Hobbit) to talk to passenger could this be my problem. will unplug PTT button in morning and find out.:D

    PTT button has no effect on headset radio stiil play's in headset even when pushed, checked for continuity on button it's fine but the wires beep the tester when checked I don't think they should. will be taking fairing back off to trace more wires
     
    Last edited by a moderator: Dec 15, 2009
  8. HOTROD 94

    HOTROD 94 Member

    15
    0
    0
    Radio now working:D John from Radio Sound is the "MAN" walked me through what plugs to disconect to track down were the problem was. The man knows his stuff took me 3 minutes and music to my ears from the speakers.Also he was really nice said he's been problem solving radios over the phone since 86 thanks to everyone who tried to help.:s
     
  9. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    HotRod 94; so we know - where did you trace the problem to? Can you tell everyone the root of your speaker/wiring problem, in case this happens to others...thanks.
     
  10. flhtcgliderider

    flhtcgliderider Member

    15
    11
    0