P0108

Discussion in 'Dyna Models' started by TopSgt, Apr 24, 2011.

  1. TopSgt

    TopSgt Member

    11
    0
    0
    I bought an 07 Street Bob for my wife last year. 8,000 on the clock. It had staight pipes and a Hyper charger. It popped on decel and would not run without the engine light coming on. I have made the follwing changes:
    Python 2-1 exxhaust for more back pressure, performance and better sound. Heavy Breather to clear her leg on the mid controls. Power Commander 3 USB uploaded map for Heavy Breather and D&D Fat Cat 2-1.

    No more popping on decel and runs great. However.

    Engine Light On all the time.

    Trouble code shows P0108

    P0108 Map Sensor Failed High Carb
    P0108 Map Sensor High EFI

    Any thoughts, suggestions, explainations would be appreciated.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. TopSgt

    TopSgt Member

    11
    0
    0
    What does the code mean by High EFI or Faile High Carb?
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    It means the ECM does not see a changing value for intake manifold pressure or it pegged for a second, then recovered. I take it your bike is Fuel injected.
    Write down the code, clear it and then see how fast it re-appears. Since the bike runs fine, it may have posted the code some time back.
     
  5. TopSgt

    TopSgt Member

    11
    0
    0
    I cleared the code, as soon as I started the motor the engine light came on, I shut it off and checked the code, I took it for a ride and the light never went out.

    Is there anyway to replace the MAP sensor without taking the manifold off?
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Never changed a Map sensor myself but others may chime in. Service manual seems to imply you should take off the manifold, but to me it looks like you can change it without removing the manifold.

    What is really strange is you say the bike runs great but yet at the same time you have a current map code. Map pressure readings are so important on an injected bike that I am surprised it runs that good. If the sensor was really bad, I would either expect your fuel mileage to be terrible or the bike lean surging like crazy. Remember that the PC III is between you map sensor and the ECM and probably reads the Map sensor information and passes it onto the ECM.
    You didn't say if the code issue started after the installation of the PC III.
     
  7. jordan2555

    jordan2555 New Member

    1
    0
    0
    Heya guys...well My 09 FatBob has been acting up the last few days and today the engine laight come on....codes were P0108, P0135, P0152...but Top mine is not running good at all....in fact its lopping and almost seems to be running off one cyclinder. Modes are: Kerker 2-1, hypercharger(recently done w/i a month). So if its like Hoople says then I can vouch mine at least doesnt run good at slower speed..at 65-75 seems to be no problem except for light being on constantly.
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Type-O ?