Oil pump problems

Discussion in 'Oil' started by Sunset, Sep 11, 2007.

  1. Sunset

    Sunset New Member

    I had previously posted that I was getting some oil pressure. I have taken line off a oil pump and it now appears that there is no pressure at all. I am somewhat of a shade tree mechanic but I need to know if there is some secret or extra caution with removing the oil pump from my 81 low rider? I have the manual and the illustration but any words of wisdom from someone more knowledgable than I. I also would assume that I would need to drain the oil and probably change it as well. I understand from HD that the oil pump assembly as a whole is very exp. $399.00 so I hope to be able to find out what the problem is when I get it our of engine. Will not be able to work on it until Wed. nite so would like to hear from more experienced minds if possilbe. This looks like something that I feel I can do.
    Please anyone add your comments.

  2. Not Very PC

    Not Very PC R.I.P

    Try this one.
    Last edited: Sep 12, 2007
  3. glider

    glider Veteran Member

    Just a few things to watch out for, the woodruff key in the shaft , a dab of grease will hold it in place during assembly. Watch that it doesn't fall out on installation and the orientation of the gears when you assemble the pump if it isn't assembled when it is shipped.Don't forget some assembly lube too.

    I'm sure it will come with installation instructions and you should have a shop manual too.

    Prime it before cranking with a trigger type oil pump.
    Last edited: Sep 12, 2007