oil blowout

Discussion in 'Oil' started by woook, Mar 8, 2009.

  1. woook

    woook New Member

    1
    11
    0
    help, i have a lot of oil blowing out of my intake when im at speed. whats wrong. i suspect bad lifters. its a 95" with se polished heads. se 258 cams. adj pushrods. se lifters 10.5 pistons. bub dual exh, roller rockers. did work myself. had no trouble for a year then it started blowing oil out of the air cleaner at speed and losing pressure. enough to cover the side of the bike. oil pressure is very low at idle and when its warm. i suspect lifters because i bought them used to save a buck. any suggestions as to what could be causing this would be appreciated.
     
    Last edited: Mar 9, 2009
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Need more info on the bike as far as what mods done. It could be anything from exhaust to oil pump alignment causing it. Why do you feel it's lifters? Overfull?
     
  3. bubba

    bubba New Member

    3
    11
    0
    ck oil filter. some times they put a evo filter on twin cams and has done this
     
  4. glide01

    glide01 Member

    72
    16
    0
    just did a 95" 37g cams rode around city.short blasts on hyway varying RPMS to seat rings once on the hyway cruising speed 1/2 quart oil everyware.Wifey very mad oil on her too. I didn't align the oil pump. aligned the pump all set now
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    That'll do it. Unless they are aligned properly, it doesn't scavenge the oil from the motor and it will back up a bit and come out the breathers.
     
  6. glide01

    glide01 Member

    72
    16
    0
    didn't notice the year ago part. sorry