No spedo & turn signals on

Discussion in 'Electrical' started by DresserDan, Aug 28, 2015.

  1. DresserDan

    DresserDan Member

    36
    16
    0
    a friend called and said that the spedo in a 06 Fatboy doesn't work and the turn signals on one side are on. Any idea's where to start looking?
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  3. DresserDan

    DresserDan Member

    36
    16
    0
    Thanks Good info Will that work on the 06 Fatboy?
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Yup, if you have any stored codes it will show:s
     
  5. DresserDan

    DresserDan Member

    36
    16
    0
    Do you think that the turn signal module could also effect the speedometer? Where do I find the TSM ? I see the parts book call it Module turn signal canceller and Module security system & turn signal canceller Is this what I need to locate?
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Duno the answer to that one, did you scan it and find any codes or part numbers show up?
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Have the bulbs been changed? Are they the correct ones? The TSM should not affect the speedo, I believe the speedo runs from the sensor on top the tranny thru the ECM
     
  8. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I may be way off base but on my 05 RG a low battery caused a bunch of electrical problems. 12.7 volts is what you're looking for and having it load tested might be a good idea.
     
  9. DresserDan

    DresserDan Member

    36
    16
    0
    I am going to check the charging system first. I have also heard that a bad regulator charging system can do the same thing.
     
  10. tourbox

    tourbox Senior Member

    1,311
    68
    54
    I think the TSM/TSSM is mounted on a removable plastic plate between the oil tank and rear fender.
    tourbox