No brakes lights with front or rear brake levers

Discussion in 'Dyna Models' started by bikerpapaw, Jun 5, 2011.

  1. bikerpapaw

    bikerpapaw New Member

    1
    0
    0
    I have an 2004 Dyna Wide glide, I have had this since new, I have no brake lights with the front brake lever or with the rear brake lever, I could use all the help I can get on this issue, thank you in advance. Biker Papaw
     
  2. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    Are you sure they,re not on and wont turn off?
     
  3. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    A little more information would be helpful...did this failure happen suddenly or after work was done to the bike? Check basics...fuse, conditions were the switches are located, front lever switch underneath at near master cylinder, rear switch is in line with master cylinder hose and is a pressure switch. Could also be wire under the fender snagged by the tire or corrosion in socket to actually a bad lamp. Careful inspection is necessary...go to self help section to see a basic wiring diagram. :s
     
  4. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,276
    133
    156
    If Brake light not working with either brake i would start at the bulb and work forward from there

    Brian
     
  5. gator508

    gator508 Senior Member

    2,308
    68
    81
    I would go along with Brian's suggestion first, since the bulb is common to both brake systems. May have corrosion on the socket, if the bulb itself is good.
     
  6. JBC2565

    JBC2565 Junior Member

    582
    28
    2
    Make sure bulb has 2 filaments and not one then re-install with dielecric grease to make sure good connection.
     
  7. Bilgeslop

    Bilgeslop Member

    19
    11
    0
    Check all the wiring inside the rear fender. I've chaffed through those wires with the tire several times. Even plays havoc with the headlight.