New to the site.

Discussion in 'New Member Introduction' started by Stormin, Jul 24, 2011.

  1. Stormin

    Stormin New Member

    2
    0
    0
    Hey everyone! I ride a 1997 Dyna Convertible. I've had it a couple of months now, and I've been having a couple of small problems. If there is anyone out there that can give me some ideas it would be much appreciated. When starting cold there is a tiny amount of black smoke from the exhaust and after warm up, the first mile down the road it backfires and pops and runs terrible, and then clears right up. I have changed the plugs but the old ones didn't look too bad anyway. Another thing is every couple of days when I go to start her it just clicks and wont turn over at all, but if I wait a bit she will finally turn over and start. I also noticed yesterday that the base gasket is seeping a small trace of oil, and I'm wondering if it is hurting it to keep running it that way? The oil is full and I keep a jug with me just in case.

    Thanks

    Stormin
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    321
    Welcome to the"BEST on the NET" Be sure to check out the Self Help Section for great tips and advice. Enjoy your stay!!!
    When posting a question for answers. Post the question in the area that best refers to question. You will receive many more responses to help you get problems corrected.:)
     
  3. glgarrett

    glgarrett Active Member

    203
    26
    0
    Welcome from Louisiana! :)
     
  4. wilks3

    wilks3 Junior Member

    623
    0
    1
    :wce
    Ride Safe!
    wilks3
    :USA
     
  5. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,526
    73
    186
    Welcome form Central Florida.

    Bodeen
     
  6. Dr. Dolittle

    Dr. Dolittle Experienced Member Contributor Retired Moderators

    6,404
    118
    28
  7. geezer

    geezer Senior Member Contributor

    1,682
    68
    65
    Welcome aboard from Canada.
     
  8. BillMull

    BillMull Banned

    71
    0
    2
    The best info on the web hands down. You will learn so much about your bike and never look any where else to find it. The people are great here! Welcome aboard and stay safe!:)
     
  9. Jack Klarich

    Jack Klarich Guest

    Welcome to The Forum, How many miles on your motor? May need a top end job, bad valve seals and or rings, 97 Evo needs warm up time they tend to be hard on gasket leaks. There are better than H D gaskets out there Cometic Gasket, Inc. :s
     
  10. Stormin

    Stormin New Member

    2
    0
    0
    Thanks everyone! There are 64,000 miles on er' Jack. It was shipped to Canada from Florida the day I bought it and I don't have any real background information about it. I try to always give it 5 or 10 minutes to warm up, but on a sunny hot day after warm up time it will run perfect with out a problem. Colder cloudy days after the warm up it will cough and backfire the first mile down the road. Someone mentioned to me the coil may be getting bad? I don't know to much about them but I'm trying to learn. I hope it doesn't need a top end job, pretty short on the cash! Thanks man!