new 2012 harley soft ails

Discussion in 'Softail Models' started by Rango, Dec 22, 2011.

  1. Rango

    Rango New Member

    3
    0
    0
    I just purchased a new soft ail blackline back in september got the new 103 motor and i keep having rear light problems on the right side ridding light goes out and the brake and blinker still work gone through 5 bulbs already and here recently replaced the clutch and and friction plates after the first 1000 mile service which and riding in a parade , i had gotten all synthetic fluid put in I'm not a rookie had a 07 peanut tanker with 130,000 miles and rode the (EDIT) out of that cause thats what you do with a sportier to keep up with the bigger bikes rode in parades in west texas heat and dust this past summer and never had any issues. Is anybody having any kinds of trouble at all with the new soft ails that have come out?

    Please read and understand the info in this link below...
    [note]
    A Friendly Reminder - Harley Davidson Community
    [/note]
     
    Last edited by a moderator: Dec 22, 2011
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Unless they have changed, you don't have a riding (running) lights on the rear, only directional lights. The running lights are on the front. Does the rear bulb have a single or double contact on it?

    You didn't mention if you have any modules for the lights.
     
  3. Rango

    Rango New Member

    3
    0
    0
    well the new ones do its a double and no i have no modules the harley davidson dealership says they don't understand why its doin it
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Are you testing the bulb when you remove it?

    There's a possibility it could be a problem with the socket.
     
  5. FerrousBueller

    FerrousBueller Junior Member

    401
    28
    7
    Sorry, can't help you with your issues. Hope it gets corrected soon.
    Just wanted to comment on your clever title!

    Cheers!