Need Help!!! I replaced battery and now it wont start.

Discussion in 'Electrical' started by jonrjenjr, Jun 9, 2010.

  1. jonrjenjr

    jonrjenjr New Member

    1
    0
    0
    I have a 2008 Night Rod Special. It has been a while since I rode it so I went out to start it up and needless to say it was dead. I took the battery out to charge it but the battery was to low to charge so I went and bought a new one. Once I got it all hooked up including the cables to battery tender I bought all that happens is the signal lights stay on. No lights on the insturment cluster or anything. I switch it to ignition and the fuel pump doesnt turn on or anything. Please help me with this problem if you can.

    Thanks,
    Jon
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Hopefully you have the kill switch on the bars to RUN. Next remove the battery cables you just installed and wire brush them and the terminals and reinstall. Remove the NEG first and install last.
    Lastly is the new battery charged fully? New batteries need to be fully charged before putting them into service.
     
  3. nvsteve

    nvsteve Member

    76
    0
    0
    You may have inadvertently grounded the positive cable when installing and popped a fuse.
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,632
    68
    99
    If it has been that long since you rode the bike that you needed to replace the bike battery, you may also need new batteries in the FOBs assuming you have the security system on that bike.

    TQ