Lights Quit Working

Discussion in 'Electrical' started by rharrold, Apr 7, 2012.

  1. rharrold

    rharrold New Member

    2
    0
    0
    My headlight, passing lamps and dash light stopped working on a 2000 Road King Classic. I have changed fuses, checked connectors along the harness, check connection on ignition switch. All seems to be as it should be. I'm not sure if I have a ground problem or something bigger. Any thoughts on how to troubleshoot the problem??
     
  2. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,591
    103
    296
    Welcome to the forum. If all fuses are good and wiring is good :Di'd be looking at a ground issue. Did you check out the self help section?
     
  3. rharrold

    rharrold New Member

    2
    0
    0
    I did check the self help section, but I'll check deeper into that section. Thanks Lawman
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    To check for grounds, if you have a test light, hook up the alligator lead to the positive of the battery, any thing you touch with the probe end will light the test light if you have a ground. The best test would be with a volt meter:s
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Here is the wiring for your bike. Let us know if you need help with meter troubleshooting.
     

    Attached Files:

  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    1st page got chopped. Here it is again.
     

    Attached Files:

  7. dbmg

    dbmg Experienced Member

    5,800
    153
    318