left and right signal lights

Discussion in 'Electrical' started by mikespride, Jul 12, 2011.

  1. mikespride

    mikespride New Member

    4
    0
    0
    My husband has a 2007 Ultra Classic and is having some trouble with his signal lights. When he turns on his left or right signal light, his four-ways will come on, it doesn't happen all the time. We are leaving for the Smokie Mountains so can anyone help on trying to fix this problem. Thanks
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    It's strange that it could be either side. The problem does not favor 1 side?
     
  3. mikespride

    mikespride New Member

    4
    0
    0
    No it doesn't favour either side, but it is strange that it doesn't happen all the time.
     
  4. mikespride

    mikespride New Member

    4
    0
    0
    no it does not favour either side, he is really worried as we don't have the time to take bike in as we are leaving on friday
     
  5. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Are all the bulbs O.E.? Was thinking like if bulbs were changed and clear or smokes lenses installed maybe a bulb is not sitting just right in the socket and creating feedback through system and lighting all 4 bulbs. Is the intensity of bulb same when all 4 blinking with turn signal on or slightly dimmer???
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Were any modes made to the bars (cable extensions etc).
     
  7. mikespride

    mikespride New Member

    4
    0
    0
    yes he has had so much work done on his bike, sound system with 8 speakers and a GPS, and I'm sure other stuff too, too bad he is not hear with me now to explain more in detail, we just don't want it to be a long and expensive fix or it will be a problem for us.
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    My guess is that this problem has just happened recently and up to this point, all has been fine.

    Did the problem start right after an electrical mod was made to the bike.
     
  9. dieselguy65

    dieselguy65 Account Removed

    79
    0
    1
    sounds like the flasher unit is bad.
    seen that before.