Is this chain OK?

Discussion in 'Transmission' started by Hammerheadc4, Jul 28, 2008.

  1. Hammerheadc4

    Hammerheadc4 Member

    9
    11
    0
    I was riding Saturday and...something didn't sound right, so I headed home. Sunday morning I checked the primary chain tension, it was 7/8. I adjusted it to 5/8

    It looked like the rivets on the side of the chain were lightly scuffed.
    Here's a link to a photo of it.

    [​IMG]

    Anyhow, I changed all the fluids Sunday and took it for a test ride tonite, everything seems to be OK, shifts smooth, runs quiet, and finds neutral very easy.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    The scuffing looks minor but what was it scuffing on, it must have been the case which brings to mind why?

    May be worth pulling the cover and check the compensator nut for proper torque and see if it too was hitting the cover. Also clean things out while it's opened up.
     
  3. Hammerheadc4

    Hammerheadc4 Member

    9
    11
    0
    Thanks Glider...If I don't have the dealer do it, I'll have a look this weekend.
     
  4. Hammerheadc4

    Hammerheadc4 Member

    9
    11
    0
    I pulled the primary cover off today and got a good look inside.

    I didn't see anything else scuffed.
    Between gaskets and oil it cost me 40 bucks.
    I'll just keep an eye on it.
     
  5. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    3
    What did the Comp. nut torque out at?