idles to low and dies

Discussion in 'Touring Models' started by johndeeredr, Mar 22, 2015.

  1. johndeeredr

    johndeeredr Member

    50
    18
    2
    got a 2012 roadglide. one morning started the engine and idle went above 2000 rpms for the first time then back to normal around 1000 rpm after around a minute. started on a coast trip went about 90 miles, came to a stop light and died. started back up and was able to get it off the road. has about 13000 miles and ran flawless to this point. disconnected the v-h fuel pack and reconnected the o2 sensors but did not make and difference, I would start but the idle was below 700 rpms. started for home, runs like normal at all speeds other than idle. ran it over to a friend of mines house about 30 miles and now seems to idle ok but may be a little rough. engine light never came on. pulled spark plugs and they appear normal, replaced with hd oem plugs about 2000 miles ago. has stage 1 air cleaner. true duals and reinharts mufflers. what could be the problem?
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    Your idle air controller may be stuck. Look in the self help section for ways to clean it. It's very easy.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
  4. johndeeredr

    johndeeredr Member

    50
    18
    2
    I was told that since the throttle is fly by wire it doesn't have this valve . is that true and were would it be located on 2012 103 engine? don't want to take this to a dealer, thanks for your help brothers,
     
  5. Breeze3at

    Breeze3at Well-Known Member

    4,641
    83
    122
    You are correct, no IAC on your bike. Maybe the fly by wire got "miscalibrated". If the throttle is moved when shutting off, it gets out of whack.
    Jack Klarich just had a problem with his FBW, maybe he has idea?
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    Are you using the kill switch to shut down the engine? I had my throttle by wire replaced @ 3500 miles. The throttle can relearn its idle position if the mechanism is not damaged. Switch the ignition on, run switch on til the pump runs, shut off ignition switch repeat 4 times if that does not reset the idle I bet the throttle mechanism has gone South

    [​IMG]
    The plastic cog on the end of the unit was stripped on mine it would not return to idle
     
  7. johndeeredr

    johndeeredr Member

    50
    18
    2
    makes a lot of sence thanks jack. also read by neutralizing the cruise control using the hand throttle going past the idle position to parade mode might take the calibration out of wack. did I mention I had a vance hines throttle pack installed at the time? I disconnected it but had same results with no idle. could the throttle pack have done this over a one year period ?
     
  8. turnerbend

    turnerbend Active Member

    231
    38
    3
    Try removing and cleaning battery cables and tighten to spec. Due to engine vibration, the cables will get loose and not allow the battery to get steady charge while running and the voltage gets low. Low voltage for some reason will cause engine to shut off at idle. Sound strange but, try it.........