Idle speed question

Discussion in 'Touring Models' started by turnerbend, Aug 16, 2012.

  1. turnerbend

    turnerbend Active Member

    231
    38
    3
    I notice that after riding in the city (stop and go) while stopped at red lights, I'm idling at below 1000 rpm oil pressure about 5-8 psi. What is your rpm and oil psi in this situation.
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    My '07 E.G.Classic is almost the same as yours. My idle is usually right at 1,000, but occasionally drops a bit. Oil pressure is the same as yours. I've trained myself to not look at the oil pressure gauge at idle. On a recent trip, 3 '07's were the same idle and pressure. A '11 with us, held 15 psi at idle.
     
  3. Trek

    Trek Junior Member

    575
    26
    1
    I think that is perfect. At least that is what mine is when it is good and warmed up.
     
  4. Rydn4fun

    Rydn4fun Member

    31
    0
    0
    I have 07egc that has done same thing since new, have 40k on bike now the main issue I have is times Idle drops to 600-700 bike never dies.I have had dealer check it out few years back no problems found.I have since replaced the TPS,and then IAC neither of these corrected problem now Im just used to it and never have had any major issues arise......Have heard of this quite a bit with the 07's not much with newer models though.

    If you care to see all the other replies I got from all the people on this site do a thread check For (07 low idle speed) I had many replies which I went through and checked all areas that were addressed maybe this will give you some things to double check and you won't need to wait for others to post.
     
    Last edited by a moderator: Aug 16, 2012
  5. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,310
    73
    130