Help with oil leak

Discussion in 'Touring Models' started by SileradoSteve, Jun 20, 2010.

  1. SileradoSteve

    SileradoSteve Member

    21
    0
    0
    I changed my oil a couple months ago and all was well for about a month and then started leaking oil, I thought it was coming from the oil filter because the wire wrap directly under the filter was wet and the oil was dripping down the wire wrap to bottom of motor and I did tighten the filter about a quarter turn but its still leaking, could it be the oil filter mount?
     
  2. fin_676

    fin_676 Well-Known Member Staff Member Moderator Contributor

    4,969
    58
    66
    If the filter had not been tight in the first place perhaps some dirt got on to the filter seal and caused the seal to fail
    might be best to remove the filter and clean the seat that the seal sits on and fit a new filter smear some fresh oil on the seal and do not over tighten the filter as it can deform the seal and cause it to leak should only be hand tight

    Brian
     
  3. glider

    glider Veteran Member

    25,464
    108
    43
    Do you have an adapter or a oil cooler on the bike?
     
  4. SileradoSteve

    SileradoSteve Member

    21
    0
    0
    No oil cooler
     
  5. ChopperDoc

    ChopperDoc Active Member

    163
    0
    1
    IF you don't have any oil around the front cylinder base and the leak is localized around the filter, it is probably one of three things - First it may be nothing more than oil spilled during the filter change that is just now working its way down and starting to drip. It is almost impossible to change the filter and not get some oil spillage.

    Second, the oil filter gasket is leaking (making it tighter may only make the problem worse) - Or the oil filter bracket is leaking (This is me hoping that your cases aren't cracked or leaking).

    I would try the cheap fix first and change the oil filter. The filter may have visual signs leakage (gasket creased, flat spot, cracked or wrinkled). After changing the filter I always spray brake cleaner all around the area to clean away any spilled oil.

    If you still have the leak after changing the filter, you should replace the oil filter mount "O" rings (HD # 11293, two required). Inspect the mount for cracks or warping and if it needs to be replaced you will need HD # 26261 (black) (includes "O" rings) or HD # 26274 if your motor is silver. Or you might want to use this opportunity to do a little chrome and add HD # 26321-99A Chrome Oil Filter Bracket ($69.95 retail).

    Hope this at least gives you a place to start looking.
     
  6. SileradoSteve

    SileradoSteve Member

    21
    0
    0
    Thanks alot ChopperDoc, I will try those things and hope for the best, really appreciate the part numbers.
     
  7. Jack Klarich

    Jack Klarich Expert Member Contributor

    17,310
    123
    113
    Hopefully not the front cylinder base gasket leaking, some times the case studs stretch and the base starts to weep then leak, good luck
     
  8. ChopperDoc

    ChopperDoc Active Member

    163
    0
    1
    No problem. Remember to check your oil level after changing the filter - You will need to replace the oil removed with the old filter.
     
  9. biscuit

    biscuit Junior Member

    558
    28
    4
    ChopperDoc's first suggestion sounds like a reasonable one.That wiring harness is a bear to clean oil from;when it dribbles in from your filter change.
    Also,do you smear oil on the filter"o" ring when you fit it?If you dont,it can bind or bunch up,not seal properly and leak despite however tight you try and turn it.
     
  10. BUBBIE

    BUBBIE Well-Known Member Contributor

    4,914
    58
    75
    Just another CAUTION as I found on my 2000 FXDS.... I think your wires to the stator are the same as my 2000....

    I would Find oil IN and around these wires after a oil change NO Matter How careful I was (filter change leakage)...

    The Caution Is OIL would Fill INTO the "Stator Coupler Plug" and "Boot"... Leaking out After normal clean-up... Ride Wind blowing oil out again after cleaned once and re-appearing as a leak..... You get my drift?

    I would check and wipe out the "Rubber Cover Boot" and UN-Plug "Coupler" to make sure the connectors are Oil Free... Mine had enough Oil in the "stator plug" to cause a short at this connector.. It is worth checking..:D

    signed....BUBBIE