Headlight Relay 09 Sportster - Load ?

Discussion in 'General Harley Davidson Topic' started by Kondor, Sep 24, 2016.

  1. Kondor

    Kondor New Member

    3
    1
    0
    Put a couple of "excellent" LED running lights on the highway bars of my 09 1200L Sporty. ( Superbriteleds.com ) They look and work great but headlight is very yellow compared to the LEDs. I purchased a couple of LED H4 headlight bulbs with intent to replace the regular bulb. LEDs will not light up. Power to headlamp plug is good. LEDs work if I test them with a 12V battery. Sooooo, question is, is the headlamp relay operation dependent upon the actual load of the bulb. A regular H4 of 12V - 55 Watts would put about a 4.5 amp load back on the relay. The H4 LEDs only put about a quarter of that. Is the relay not closing when the LED is in the lampsocket? Any ideas? I'm not electrically educated enough to completely understand loads and feed back loads.
     
  2. gator508

    gator508 Senior Member

    2,308
    68
    81
    I'm not an expert, but I do believe the load is not enough. A load equalizer may solve the problem, hopefully some of the "experts" will chime in to help. Good Luck!
     
  3. Kondor

    Kondor New Member

    3
    1
    0
    Thanks Gator... I'm going to have a long winter to experiment..
     
  4. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,597
    103
    296
    Take a look in the self help section of the forum, I believe this issue has been covered. I believe Russ has you covered tho.
     
  5. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Usually when purchasing bulbs, the parts store expert should be able to help. You usually can not just remove O.E. bulbs and install LED with out updating with additional component for LED.
     
  6. Kondor

    Kondor New Member

    3
    1
    0
    Yep, seems I didn't do enough homework. Thanks everyone.