H.K. Stereo problem...

Discussion in 'Touring Models' started by FLHTrider08, Aug 25, 2011.

  1. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    I have an 08 EG Standard with an add-on (from factory) H.K. stereo/CD player. I recently started up my bike and noticed that the radio/stereo handlebar controls don't work and the CD player (which has a disk in it) won't play but shows the track #. The AUX port with my iPod doesn't work either. The CD in it has worked before and was the last one in (for a few days) before it died. I've tried pressing /pressing and holding the stereo's buttons down without any change. I've also looked in the H-D Service service manual (for my Dad's 06 Ultra with same stereo I think) and it has next to zero troubleshooting info other than checking the fuses (were o.k.) and taking it to the dealer. Anything else I can try? :33:
     
  2. JBC2565

    JBC2565 Junior Member

    582
    28
    2
    I know they had an HK software update to fix a few issues. Not sure if your issue is one though. Have a look at link below to see if it will help.

    Harley Davidson Community
     
  3. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    Thanks STEVE07. I couldn't reach it with the tweezers. As best I can tell its sitting in a tray below the door. That prevented me from being able to get it out as I couldn't get the tweezers angled down enough to make it fit. Thanks for the help anyways.
     
  4. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    If the update requires a CD, I'm stuck as I can't eject the one thats currently in there.

    I may have to take it to the dealer. I read on an old post that it may also be a broken wire which is causing a problem. I tried to "jiggle" the wiring harness in front of the gas tank under the fairing with no luck though.
     
  5. Poser

    Poser Member

    21
    0
    0
    There was a tech tip (I just looked and couldn't find it.) on HogTunes site that said to leave the CD door open and go for a 20 minute ride. I would try this before sticking things inside. The worst that can happen is it doesn't work but you went for a ride:)
     
  6. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    Thanks Poser. That sounds an easy possible fix. I've already tried 2 attempts at fishing the cd out without success.
    [​IMG]
     
  7. Woollymonster

    Woollymonster Account Removed

    8
    0
    0
    When I started looking for a new bike this year I was looking for the EG Standard. I was surprised to learn that it is no longer offered. I am just one of those riders who prefers a bike without all the electronic Chinese gadgetry on it. And I did not want the lower fairings either. I was planning to configure it with a detachable trunk like my Road King for long hauls.

    When I was shopping, of course the dealers were trying to sell me something I didn't want, "Just look at this '11 Ultra. Look at all the options. It even has an intercom so you can talk to the passenger!"

    To wich I promptly replied, "When I head out on my bike, the last thing I want to hear is her back the yammering." Everyone in earshot fell about the floor.

    So after a week or two in the saddle of my EG Classic, I find that the stock stereo (I presume the same as yours) is pretty much useless at any speed other than parade speeds and stop lights. At over 50 mph, it is just a bunch of background noise. It has functioned flawlessly so far but I rarely use it. I have been on Ultras and the stock 4 speaker setup sounds much better.

    Also read an article in one of the V-twin rags on the install of the new HD Boom 2 speaker and amp system in a Street Glide (I think) and they had good things to say about it. Louder, clearer, more fidelity. So, do I drop the $600 for more Chinese gadgetry? Probably not.

    To each his/her own. Later, I'm going riding.
     
  8. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    I got it in to the dealer and they ordered a new stereo on extended warranty. Unfortunately they gave me an ETA of between 3 days and 6-8 weeks. If its 6-8 weeks there will likely be snow on the ground here!
     
  9. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    My new stereo has arrived at the dealer and my appointment is Saturday. Hopefully it will fix everything.
     
  10. FLHTrider08

    FLHTrider08 Active Member Contributor

    201
    26
    0
    I finally got my stereo in and it works great now.