Gen 3 settings

Discussion in 'TFI Questions Answered By Dobeck' started by fiveoh455, Apr 21, 2012.

  1. fiveoh455

    fiveoh455 Active Member

    116
    28
    1
    I installed a Dobeck Gen 3 on my 2012 Road King. Everything on the bike is stock. According to the guys at Dobeck, the Gen 3 is programmed/delivered set up for stage one. They advised I set the Green, Yellow and Red modes back 1 point. So the current settings are Green 2.5, Yellow 1.5 and Red 1.5. The GB, YB and RB were not changed (8, 4, 4.5 respectively.)
    My mileage dropped to 34 in town and 33 hiway after I installed the Gen 3. Looking for some advice on settings.
     
  2. Streetglider08

    Streetglider08 Member

    89
    0
    0
    I experienced the same problem with my 08' street glide. I tried all kinds of different settings with the green, yellow, and red settings nothing did the trick. Then I reread the instructions, and what each color represents. Yellow/blue is the switch point from cruise mode to acceleration mode. I turned that up .5 from the recommended setting and am now getting 40 mpg with no performance loss at all. I called doebeck and they agreed 100% with my findings.
    If I were you I wouldn't hesitate to give that a try. After installing my ejk I was down to about 170 miles per tank. I am now back at 200 miles with the same riding style. Although when I get on it often I see a small drop in mpg, but that is to be expected.
     
  3. fiveoh455

    fiveoh455 Active Member

    116
    28
    1
    Thanks Streetglider08....I'll give that a try. I spoke with a tech at Dobeck. He suggested I turn the Green mode back another point, which I did. That raised my hiway mileage back up to approx. 38 mpg. I'll turn the Y/B up .5 and see what happens.
     
  4. GroundHawg

    GroundHawg Active Member

    147
    26
    0
    Just curious - is your bike stock or have you done a stage 1? My mileage dropped after installing the Gen3, which was part of my stage 1. Bumping the green to 3 (down from 3.5) helped a little bit.
     
  5. Streetglider08

    Streetglider08 Member

    89
    0
    0
    Stage 1 for me.
     
  6. GroundHawg

    GroundHawg Active Member

    147
    26
    0
    Looks like an increase by .5 in to the YB is in my future!

    Thanks!
     
  7. bcortani

    bcortani Active Member

    392
    28
    3
    Sounds like you got your answer, I have the Dobeck and installed it as it came without adjusting anything. I have now finished my stage 1 and am wondering if I need to tweak it a bit. I have 08 FLSTC with the below (my tag line area) set up. My speedo/odometer says at full tank I am good for about 209 miles which equates to just about 42 MPG. Question...is that where I should be or can it be better. Bike runs and sounds great. Just curious. I love learning my bike....and not trying to jack this thread. thanks. Bill C. Oh yeah, going on a rain ride tomorrow with friend around the Hwy 101 loop in Pacific Northwest of Washington state (Forks to Aberdeen then over to Shelton and back to Sequim back to Forks). Should be cold, wet and FUN!!.
     
  8. Streetglider08

    Streetglider08 Member

    89
    0
    0
    I am no expert but I would say if it's running good then I wouldn't change anything. 42 mpg is great.
     
  9. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    With my TFI installed on my 09 FLHR, Set PROPERLY, running GOOD, it never got better than 40 MPG but did it Every Time out. Regardless of 1 or 2 up.

    I tried for more MPG by re-adjusting the green pot (one) leaner but the best over all was where it was getting 40 MPG.

    You can remove some fuel but like others have said,,,, Running Good Leave it there.

    Remember, WE want the bike NOT TOO LEAN...
    In order to do that, the mileage may/will go down a little.

    Now on my beta Gen4, I'm able to lean it out when on the road and have gotten 47+ MPG Choosing when I run it a LITTLE lean.

    On the HDT meet n greet run, morning up was cool and 14.2-4 was good setting for the Freeway ride up. It was VERY HOT out later morning, so I kept my AFR at 13.2/4 area and the bike Loved it there.

    Normally running at 14.2 on the highway, it's gets the 47mpg but I'm sure it did dropped a little at the 13.2-4 setting.

    SilverfoXD had his Stage one/510 cams (HD type fueler?) Dyno set at 13.1 and it sounded and ran real Good. He was out in front of me and never lagged a bit when The Tank gave it the GUSTO :panic
    (just a little now and then)

    MY TFI worked great and it was hard to take it off my King to Beta the gen4 but I'm liking the gen4. Some issues yet on acceleration gas coming on off idle when starting out.
    (I'll use a Borrowed PC (i'm Mac) with infra-red dongle to change the program a bit)...

    IF and when I put on a Gen3 (next), I will probably get no more than 42 at the Better setting for my 09 FLHR using SE255 cams and fully stage one/stock 96 yet and no head work YET...

    So, I'd be happy with the 42 and have the bike run GOOD like you stated.

    Just My Way :newsmile03:

    signed....BUBBIE
     
  10. fiveoh455

    fiveoh455 Active Member

    116
    28
    1
    Following Streetglider08's advice, I bumped my Y/B setting up .5. I also bumped the Green setting up .5, to 2.0. After running through a full tank (mostly in town riding/cruising) my mileage is back up to just over 39 MPG. I have a road trip coming up in a few weeks, so I'll have a chance to check the hiway mileage.
    Thanks again Streetglider08....just curious, will another .5 bump on the Y/B do even better?