FLHR runs irregular at startup

Discussion in 'General Harley Davidson Topic' started by plow boy, Nov 3, 2012.

  1. plow boy

    plow boy Member

    79
    18
    2
    Yesterday the weather here in Carolina was cold,38 degrees.When I turned the ignition on,the yellow light on the dash that usually comes on for a few seconds then goes out,didn't come on.I usually wait for this light to go out before starting, since it didn't come on I tried it. It started and cut off twice the third time I played with the throttle it started but ran raggedy for a few seconds then smoothed out.After my trip [45 mi] every thing was fine,came back home and made a few more short trips just to check ,it was fine.Today it acted up just like yesterday 40 mile ride,stoped and ate lunch,started home it started and ran normal.Arived home,let it sit for two hours, tried it again,no yellow light,hard to start but smoothed out.I guess what I'm asking is does anyone know what is going on to cause this light to not come on and not want to start? [2012 rk]
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    If you don't get any results from the DTC codes, I would let the dealer know what it is doing and let them take a look.
     
  3. stray dog

    stray dog Junior Member

    443
    26
    0
    Do you hear your fuel pump turn on for a few seconds before start up?
    Do you use the run/stop switch and ignition switch? or just the ignition switch?
     
  4. plow boy

    plow boy Member

    79
    18
    2
    Thanks Tank and HDDon I feel like the ruff idle and the yellow light kind of go together since it runs and starts fine when the light comes on when I turn the ignition on.I didn't know about the bike showing codes,I checked out the page with codes,maybe with the wife's help we can check it. Thanks a lot,I'll post results.
     
  5. plow boy

    plow boy Member

    79
    18
    2
    Stray Dog I don't think that I heard the fuel pump but can't be sure.I'll check that,I haven't been using the switch on the bars.Thanks for your reply.
     
  6. plow boy

    plow boy Member

    79
    18
    2
    Thanks again Tank ,hope to check the codes tomorrow.
     
  7. DFHarley19

    DFHarley19 Active Member

    390
    0
    0
    I am not sure if your bike has warranty. If so then you should send them to dealer and have them check... But I would like to hear from others how to solve that problem. :D
     
  8. Checkers

    Checkers Member

    29
    0
    0
    May want to clean and tighten battery cables before doing anything else. Are you running a tuner? ECM may have to relearn thru a few cycles with the colder weather. How many miles on the plugs?
     
  9. plow boy

    plow boy Member

    79
    18
    2
    Checkers I was going to check the battery cables but after removing the seat we decided to wait until the next morning ,we did unsnap the square thing that fits over the battery but went no further,it was getting kind of cold in the shop.Yesterday I turned it on a few times every thing was back to normal,didn't start it.Tank I hope that I get a chance today to check thoses codes,The service manager\wife is bent on horse stables built this week.I will be taking your advice about the on\off switch on the handlebars. Checkers I 'm running a Sest,was running a Dobeck ejk,dealer removed it when I had cam changed.