Fatboy Ignition Switch

Discussion in 'Engine, Fuel and Exhaust' started by jroe_7, Aug 21, 2009.

  1. jroe_7

    jroe_7 New Member

    2
    1
    0
    Hey all. I've got a 2001 fatboy that I am trying to replace the ignition switch. I've removed the old switch but can't figure out how to get the wires (3 pronged) to stay in the new wire harness. Any help would be much appreciated...I'm dying to get back on the road. Thanks.
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Should be tabs on the end terminals that retain the wires in the plug. You may have to lift them up so they hook in better.
     
  3. jroe_7

    jroe_7 New Member

    2
    1
    0
    Thanks for the tip...got the wires in and the switch hooked up. Another problem though...the guys at Harley said the ignition switch was my issue but apparently not. After hooking the new one up, I still have my problem. The switch doesn't work for "ignition" but it does for "accessories". i.e. when I turn the switch to "accessories", the lights come on, odomoter comes on, etc. But when I turn the switch to "ignition", I get nothing. No odometer, no lights, no nothing. Any idea what the problem could be?
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    If you had that same problem with the other switch, it's time to start checking the wire off the switch that runs the ignition circuits with a meter or test light. Check fuses and see where you are loosing the power, possibly a misplaced connection in a plug in the harness. Open them all and clean and use a bit of dielectric grease in them.