Discussion in 'Softail Models' started by Longhair, Oct 30, 2007.

  1. Longhair

    Longhair Member

    Hi every one, I have a 97 softail When I up shift in any gear some times it goes right in gear. Other times it does not, I have to let up on the shifter and shift again then it goes right in. I do not here any grinding. Does any one know what it could be. Or is that the way it is ,thanks.
  2. glider

    glider Veteran Member


    Thank you Hobbit!

    Being a 97, there are two things that come to mind about your problem

    The first is the shift shaft is not as free as it should be due to some corrosion and grease washout over the years. It needs to be disassembled and then cleaned and greased so it operates free. If you disconnect the rod that goes between the shifter pedal shaft and the trans arm at the shifter end , you may find that the shift arm is not free at all but rather binding and dragging some. This will tell you if this is the problem or not. It would have to be unbolted anyhow to facilitate the servicing of the same. It should be done in any event due to the year of the bike and is very easy to do. If you are handy with tools, you can even drill the boss and tap it for a zerk fitting.
    Check this post out to see what I mean.


    The second thing is the shift arm itself that the peg attaches to. It may have to be moved downward so when you lift your foot to shift to the next gear it will get more of a throw. Your foot can move downward more than upward at the ankle.
    You do this by removing the bolt that holds it on to the shaft and dropping the pedal on the spline one maybe two splines depending on how high it is now. Try one spline first to see if it helps.

    The second is a minor adjustment an takes about 2 minutes.
  3. Longhair

    Longhair Member

    Thank you Hobbit And Glider for the info. I will let you know what it was .