Engine light 04 road king

Discussion in 'Engine, Fuel and Exhaust' started by INTHEWIND2, May 24, 2010.

  1. INTHEWIND2

    INTHEWIND2 Member

    12
    0
    0
    I am having a runability issue with my 04 Road King. When i start it first thing in the morning i runs terrible ie. idles rough-loss of power. The engine light stays on for 8 sec. then goes off. If i let it idle for a few minutes it goes away. I also notice that it idles fast for about a minute or so which i does not do normally. Should i run some injector cleaner?
    thanks
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    See if you have any stored codes.
     
  3. INTHEWIND2

    INTHEWIND2 Member

    12
    0
    0
    I guess that should be my next step.
    thanks
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
  5. INTHEWIND2

    INTHEWIND2 Member

    12
    0
    0
    THANKS! I was able to pull the code p1353-ft cyl no combustion. Can you give me any more specific's of this code? Both cylinder sound as though they are firing. Maybe not at first start in the morning.
    thanks
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    No combustion means the "system" has detected an engine miss. The system in this case is the Delphi ion circuitry which is part of the ignition coil.

    Anything that would cause an engine miss would post a code such as this. I always want to know ahead of time if the foundation for generating power is sound so I always perform a compression check. That tells me up front if I am spinning my wheels. If good, then I would check a few of the simple things like a bad plug, wire, or sluggish injector.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    June 7, 2004
    2004 Twin Cam Combustion Codes
    There have been reports that some production 2004 EFI Twin Cam vehicles
    intermittently set codes P1353 and P1356. These vehicles were stock and had no
    drive-abilityissues. An investigation determined that the 2004 ECM calibrations may
    allow these two codes to be set without any actual combustion problem. Calibration
    changes correcting this potential issue went into production vehicles built after May 3,
    2004.
    The revised calibrations are included in the Digital Technician software, version 12,
    recently shipped to your dealership.
    Although rare, it is possible to encounter either or both of these codes on a stock,
    production 2004 Twin Cam vehicle built prior to May. If so, simply download the new
    stock calibration using Digital Technician
     
  8. INTHEWIND2

    INTHEWIND2 Member

    12
    0
    0
    Thanks for the info! I changed my plugs and i still have the same problem so i called my local shop to get it looked at. They told me they have had a big problem with the ethenol add to the gas causing moisture build up in the fuel and gumming up carb and f/i units. he suggested an additive..i'll try it and let you know. thanks

    Well i used the additive that was suggested by my local bike repair shop and it worked. The bike is running fine now. thanks for the help!
     
    Last edited by a moderator: Jun 2, 2010
  9. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Great Feedback. And you did not have to spend a lot of dough.!

    If you get a chance tell us which additive you used. Nice to know which ones really work since there are so many to choose from..:p
     
  10. INTHEWIND2

    INTHEWIND2 Member

    12
    0
    0
    Last edited by a moderator: Jun 4, 2010