electrical problems on my 03 Fatboy

Discussion in 'Softail Models' started by patsox, Nov 29, 2007.

  1. patsox

    patsox Member

    14
    11
    0
    Hi Guys
    While riding my bike the other day I noticed my speedometer and odometer will just cut out then come back sporadically. I am not quite sure what the problem is. I replaced the battery a month or so ago but bike starts up and runs fine.
    Any help or advice is greatly appreciated
    thanks
    Sean.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Last edited: Nov 29, 2007
  3. patsox

    patsox Member

    14
    11
    0
    when this happens I lose my directionals altogether. I wonder if it is still recording my mileage? I will go to the link you sent me but while I have your attention is this easy to fix and inexpensive or will this be an early Christnas present to myself.
    Thanks
    Sean
     
  4. glider

    glider Veteran Member

    25,464
    108
    44

    One bolt and about $50 will fix it. The mileage will stop also when it is in this condition and so will other systems that rely on the output from this unit.

    I notice you said you loose the signals altogether. Do you mean the lights go out completely? That could point to a problem in the ignition switch or wiring to it. Also check your battery terminals to make sure they are clean and tight. If necessary remove them , wire brush the cable end and the battery terminal and reinstall them. Take a look at the terminals on the back of the ignition switch to see if they are corroded also.
     
    Last edited: Nov 29, 2007
  5. patsox

    patsox Member

    14
    11
    0
    thanks man..I appreciate the help
    S
     
  6. Spike King

    Spike King Member

    64
    16
    0
    May want to check battery conections to see they are tite :x
     
  7. patsox

    patsox Member

    14
    11
    0
    will do...thanks everyone
    Ride safe