Dobeck GEN 3 install on 09 Ultra

Discussion in 'Touring Models' started by smartguy, Apr 8, 2013.

  1. smartguy

    smartguy Member

    Dobeck GEN 3 install on 09 Ultra
    First off I ordered the GEN 3 a couple of months ago, so I would have it when the snow melted. I called tech support and made sure I ordered the right #, and received the Military discount. The unit only took a couple of day to get to my house. Now I had to wait, for the temp to go up and the snow to go down…
    Finally nice weather, the hardest part of the install was the pre ride… 200 miles plus to empty the winter gas out knowing the GEN 3 is sitting in the garage on the bench. Using the included instructions and the HD service manual it went pretty fast. Take off seat; disconnect battery (neg. side); remove fuel tank; run wires threw back bone; unclip plugs on Injectors, clip to GEN 3 harness back on to injectors; locate connector at each O2 sensor; unplug, clip the supplied bypass connectors on. Put the bike back together. I ran the GEN 3 wire harness in front of the battery, the unit is mounted behind the left side panel next to the fuse box. I took the mounting screws from the fuse box to give me some room to tuck the unit between the frame and the fuse box for clean look. I connected the wire from the unit with the neg. wires to the battery. Turned the ignition on; and lights flashed on unit indicating a good install.
    After hitting the first gas station I went on a long ride. Fills like a new bike; lots more power, deeper exhaust rumble, seems a little cooler. Gas Mileage is down a bit (5 mpg), however this is just my first tank so will see. I have a little bog at around 65-70 MPH, for a second or two, than off we go. FYI the stage one was done at the same time, it took me about 1 ½ hours total. It is a pretty easy install, with basic tools. Sorry no pictures, I haven’t mastered that skill on this site yet.
  2. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    Good job, now ride her :aplike ya stole her!
  3. turnerbend

    turnerbend Active Member

    Have the Dobeck Gen 3 on 07 Ultra. What are your settings? Gas milage did drop. Still playing with the tuning.....
  4. smartguy

    smartguy Member

    I'm still on factory settings: 3.5 2 2 .5 4 4.5 my mileage is about 38MPG. I'm thinking about dropping the first (green) set to 3, not sure what to do about the (roll on) bog at higher speed in 6th gear.
  5. FerrousBueller

    FerrousBueller Junior Member

    What is your speed when you do a roll on in 6th gear? RPM's if you have a tach? Maybe You need to kick it down a gear?

    I have a Gen 3 on my '09 Softail, I like it a lot. But, I don't expect to much "Giddy Up" in 6th unless I'm at 65+. Your bike is heavier than mine, a downshift may be in order to wake it up from "Cruise" to "OK, Let's get a move on".

    A call to Dobeck would help too, they might be able to sort it out very quickly. Or, go out for a day and plan on playing with the settings and enjoying yourself.