Cruise Control not setting

Discussion in 'Electrical' started by prodaytrader, Jul 19, 2009.

  1. prodaytrader

    prodaytrader Member

    44
    6
    0
    I cant seem to get the cruise control to work for some reason. I have a left on/off switch for the cruise control, which I switch on and get a red light for it. Then I pull the right switch towards the end of the handle bar which is supposed to set the cruise but it doesn't. I have tried both directions on the switch and it doesn't set. Is there some other reason why I cant get it to work?
     
  2. HarleyHarry

    HarleyHarry Banned

    548
    0
    0
    I assume you are going over the required 30 MPH?
    If so you're doing it all correct and it should work. Pushing foreward is "resume" so that wouldn't because there's nothing to "resume" with.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44

    It may need a throttle cable adjustment that operates the switch.

    Cruise Control Diagnostics and Codes - Harley Davidson Community
     
  4. prodaytrader

    prodaytrader Member

    44
    6
    0
    you must have seen my other post. There does appear to be an issue with my front brake handle. I was being tailed the other night and I was told the brake flickers on/off. It seems my front brake handle might be loose or something. If I push forward on the brake handle it doesn't flicker, but as soon as I use the brake and let go, it goes back to it's loose position and starts to flicker the switch. So this must be the issue then. How do I go about adjusting the brake to keep it from throwing the switch? I probably need to tighten up the brake line as well since I have to pull the handle 75% or more before I actually engage the brake which seems to me too relaxed. I should think no more then 50% pull would be ideal, right?